Closed Bug 1102437 Opened 8 years ago Closed 8 years ago

Logged in users should not receive notifications from Rooms created by Guest and vice versa

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
2

Tracking

(firefox35+ verified, firefox36+ verified, firefox37 verified)

VERIFIED FIXED
mozilla37
Iteration:
37.2
Tracking Status
firefox35 + verified
firefox36 + verified
firefox37 --- verified
backlog Fx35+

People

(Reporter: mreavy, Assigned: mikedeboer)

References

Details

Attachments

(1 file)

As a logged in user, I want to receive notifications from Rooms I created while I was logged in -- not notifications created by Guest

Similiarly, Guest should not receive notifications for logged in users.  Guest should receive notifications created by Guest.
backlog: --- → Fx35+
Priority: -- → P1
No longer blocks: 1074659
Points: --- → 2
Depends on: 1074659
Flags: qe-verify+
Flags: firefox-backlog+
OS: Windows 7 → All
Hardware: x86_64 → All
Blocks: 1074659
No longer depends on: 1074659
[Tracking Requested - why for this release]:
We need this fix for "Rooms", which is already enabled in Fx35.
hi mike - are you going to be able to finish off this week?  otherwise Maire will find someone to assign.
Flags: needinfo?(mreavy)
Flags: needinfo?(mdeboer)
Status: NEW → ASSIGNED
Iteration: --- → 37.1
Flags: needinfo?(mreavy)
Flags: needinfo?(mmucci)
Flags: needinfo?(mdeboer)
Added to IT 37.1
Assignee: nobody → mdeboer
Flags: needinfo?(mmucci)
Iteration: 37.1 → 37.2
Attachment #8533648 - Flags: review?(standard8) → review+
https://hg.mozilla.org/mozilla-central/rev/13e45db8c453
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #0)
> As a logged in user, I want to receive notifications from Rooms I created
> while I was logged in -- not notifications created by Guest
The icon no longer gets blue, but I still hear the sound notification when the guest joins the call.
Comment on attachment 8533648 [details] [diff] [review]
Patch v1: make sure only push updates for the appropriate channel are processed

Approval Request Comment
[Feature/regressing bug #]: Rooms

[User impact if declined]: confusing overlap between Guest and FxA-signed-in modes - you see updates for the Guest if you're signed in, or for FxA if logged out.

[Describe test coverage new/current, TBPL]: On m-c for days; Tests updated to cover this case.

[Risks and why]: Actual patch is tiny; couple of lines; 90% of the patchfile is updates to the tests.  Low risk.


[String/UUID change made/needed]: none
Attachment #8533648 - Flags: approval-mozilla-beta?
Attachment #8533648 - Flags: approval-mozilla-aurora?
Attachment #8533648 - Flags: approval-mozilla-beta?
Attachment #8533648 - Flags: approval-mozilla-beta+
Attachment #8533648 - Flags: approval-mozilla-aurora?
Attachment #8533648 - Flags: approval-mozilla-aurora+
(In reply to Paul Silaghi, QA [:pauly] from comment #7)
> (In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #0)
> > As a logged in user, I want to receive notifications from Rooms I created
> > while I was logged in -- not notifications created by Guest
> The icon no longer gets blue, but I still hear the sound notification when
> the guest joins the call.
I'm not sure this is fixed. Maire?
Flags: needinfo?(mreavy)
I've tested some variations (on Aurora), and all seem to work.  There may be some bugs (perhaps fixed in a later bug) where some updates are missed when you log out and log back in, but I definitely didn't see any updates I shouldn't get.  This may be a server issue
(In reply to Randell Jesup [:jesup] from comment #11)
> I've tested some variations (on Aurora), and all seem to work.  There may be
> some bugs (perhaps fixed in a later bug) where some updates are missed when
> you log out and log back in, but I definitely didn't see any updates I
> shouldn't get.  This may be a server issue

Yes, I believe this bug is fixed based on my testing.  

Randell -- can you open a bug (or bugs) for any missed updates?  I would file this new bug (or bugs) under Loop::Server.  Thanks.
Flags: needinfo?(mreavy) → needinfo?(rjesup)
Forget about comment 10, everything works fine.
Verified fixed FF 35b5, 36.0a2 (2014-12-19), 37.0a1 (2014-12-19) Win 7.
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #0)
> As a logged in user, I want to receive notifications from Rooms I created
> while I was logged in
As a note here, you won't receive any notification if you're logged in and share the URL with a guest.
See Also: → 1113723
Clearing NI - it appears that the issue is fixed as per comment 14, no follow-up bugs required.
Flags: needinfo?(rjesup)
You need to log in before you can comment on or make changes to this bug.