Sometimes no sound when another participant joins a user's room

VERIFIED FIXED in Firefox 35

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mreavy, Assigned: mikedeboer)

Tracking

unspecified
mozilla37
Points:
2
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox35 verified, firefox36 verified, firefox37 verified)

Details

Attachments

(1 attachment)

We're hearing reports that if a user is not in the room and someone joins, the system notification shows up and the icon gets blue, but there is no sound.

This bug is about investigating why there is no sound in certain cases and fixing it.
A few folks have been caught by surprise to see someone waiting in their room because they expected to hear a sound.  The system notification show up and icon gets blue, but they aren't hearing a sound.
backlog: --- → Fx35+
Priority: -- → P2
Well, this is expected behavior due to http://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser-loop.js#238

We left out playing a sound separately, because the notifications play their own default sounds. However, that might not be the case on all platforms, so the best we can do here is play the sound on all platforms _except_ OSX.

How does that sound? (no pun intended ;) )
Points: --- → 2
Flags: qe-verify+
Flags: firefox-backlog+
OS: Windows 7 → All
Hardware: x86_64 → All
Definitely, all platforms except OSX are better than nothing.  Is there anything we can do/play for OSX?   (Even an ugly hack.)
Assignee: nobody → mdeboer
Duplicate of this bug: 1114496
Status: NEW → ASSIGNED
Iteration: --- → 37.3
Flags: needinfo?(mmucci)
Attachment #8540763 - Flags: review?(MattN+bmo) → review+
Comment on attachment 8540763 [details] [diff] [review]
Patch v1: play a sound when someone joins a room

Approval Request Comment
[Feature/regressing bug #]: Rooms

[User impact if declined]: Inconsistent playing of sounds when users enter the room

[Describe test coverage new/current, TBPL]: on mc shortly.  Automated tests aren't reasonable for this.  Will manually test.

[Risks and why]: Very low risk change; virtually a 1-liner

[String/UUID change made/needed]: none
Attachment #8540763 - Flags: approval-mozilla-beta?
Attachment #8540763 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/3d3e53c0b21a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Attachment #8540763 - Flags: approval-mozilla-beta?
Attachment #8540763 - Flags: approval-mozilla-beta+
Attachment #8540763 - Flags: approval-mozilla-aurora?
Attachment #8540763 - Flags: approval-mozilla-aurora+
Added to IT 37.3
Flags: needinfo?(mmucci)
Iteration: 37.3 → 37.2
Verified fixed FF 35 RC, 36.0a2 (2015-01-06), 37.0a1 (2015-01-06) Win 7.
You need to log in before you can comment on or make changes to this bug.