[Music] When searching for a song not stored in the music app, the app closes the search and no error message is given

RESOLVED FIXED in 2.2 S6 (20feb)

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: fmuyumba, Assigned: hub)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.1-exploratory-3], )

Attachments

(8 attachments)

Reporter

Description

5 years ago
Description:
When the User searches for a song that is not stored in the music app,the app closes the search and no error message is shown
   
Repro Steps:
1) Update a Flame device to BuildID: 20141120001207
2) launch "Music"
3) Scroll down to expose the "search Music" search box
4) Type in any song that is not stored in the app
5) Tap "Enter"
  
Actual:
The search is closed and no explanation is given
  
Expected: 
The User gets an error message
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141120001207
Gaia: f8d3bf44029e0afc0124600a4bb34dba8fc1ad21
Gecko: f70a67a7f846
Version: 34.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 100%
See attached: video clip & logcat: http://youtu.be/StsTSrXeJgE
Flags: needinfo?(dharris)
Reporter

Comment 1

5 years ago
This issue repros on Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash) and  Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)

Result:
When the User searches for a song that is not stored in the music app,the app closes the search and no error message is shown

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141120040205
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 6ce1b906c690
Version: 36.0a1 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

------------------------------------------------------------------------------------------------------

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141120000206
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: 54f1b0ee07a6
Version: 32.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
[Blocking Requested - why for this release]:

The list of songs populates as the user types in the search box. However it is confusing that when the user taps the magnifying glass, it does not tell the user that no results were found. Nominating this to block, as it makes the music search appear broken.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
(In reply to Derek Harris [:DerekH] from comment #2)
> [Blocking Requested - why for this release]:
> 
> The list of songs populates as the user types in the search box. However it
> is confusing that when the user taps the magnifying glass, it does not tell
> the user that no results were found. Nominating this to block, as it makes
> the music search appear broken.

At this point in 2.1 keeping in mind this isn't a regressions and we cannot add more stings, we may have to live with it. But we should fix this in 2.2 hence blocking.
blocking-b2g: 2.1? → 2.2+

Comment 4

5 years ago
Jacqueline/Hub,

Hub can you work with Jacqueline and get the message added. 

Thanks
Hema
Flags: needinfo?(jsavory)
Flags: needinfo?(hub)
Assignee

Comment 5

5 years ago
I'll take it. I'll wait on a UX spec though.
Assignee: nobody → hub
Flags: needinfo?(hub)

Comment 6

5 years ago
Jacqueline, can you provide your input?

Thanks
Hema
Currently we have a pattern for this in the contacts app that should apply here as well. 
If the user types in a query that has no results, a message should appear in the space that shows results that says "No music found". If the user taps the enter button, no action should take place and the user should not be taken out of the search flow. 

Hub, let me know if this is clear enough, I can create a spec if needed but the contacts app acts the same way.
Flags: needinfo?(jsavory)
Assignee

Comment 8

5 years ago
That should be clear enough.
Status: NEW → ASSIGNED
Assignee

Updated

4 years ago
Depends on: 1106970
Assignee

Comment 9

4 years ago
(In reply to jsavory from comment #7)
> If the user taps
> the enter button, no action should take place and the user should not be
> taken out of the search flow. 

This specific bit has been dealt with in bug 1106970.
Assignee

Updated

4 years ago
Attachment #8559343 - Flags: review?(dkuo)
Assignee

Comment 11

4 years ago
This show the UI with this patch: I chose to display the message in the same still as the headers.
Comment on attachment 8559343 [details] [review]
[PullReq] hfiguiere:bug1102481-no-results to mozilla-b2g:master

Hub, thanks for working on this, I have tested the patch and it works nice, there is a minor issue(use toggle to change the hidden class) but I think you already fixed it on github, so looks good to me!
Attachment #8559343 - Flags: review?(dkuo) → review+
Comment on attachment 8559343 [details] [review]
[PullReq] hfiguiere:bug1102481-no-results to mozilla-b2g:master

Jacqueline, would you please review this? it would be nice to also have this ui-review+ :)
Attachment #8559343 - Flags: ui-review?(jsavory)
Assignee

Comment 14

4 years ago
Let's land this. I'll leave open in case ui-review needs adjustements.

Also will wait for the ui-review to submite for uplift to 2.2
Keywords: checkin-needed
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][leave-open]
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 16

4 years ago
(leave-open is a keyword, not a whiteboard status)
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Whiteboard: [2.1-exploratory-3][leave-open] → [2.1-exploratory-3]
This is looking good, the only thing I would change is the "No music found" text should follow the style that contacts has. I'm not sure that the header style is the best choice for this area.  
Ni? On Hung to confirm the visuals.
Flags: needinfo?(hnguyen)

Comment 18

4 years ago
Can we match the visuals to what is currently being used in the "contacts" app? Same layout but invert the text to "white". 

Thanks!
Flags: needinfo?(hnguyen)
Assignee

Comment 20

4 years ago
Comment on attachment 8562400 [details] [review]
[PullReq] hfiguiere:bug1102481-no-result-layout to mozilla-b2g:master

This change the style to match contact. Only HTML and CSS changes.
Attachment #8562400 - Flags: review?(dkuo)
Assignee

Comment 21

4 years ago
Screenshot after the second patch.
Assignee

Comment 22

4 years ago
Comment on attachment 8562400 [details] [review]
[PullReq] hfiguiere:bug1102481-no-result-layout to mozilla-b2g:master

Hung, 

I have attached a screenshot taken with these changes. If you don't mind reviewing it. Thanks.
Attachment #8562400 - Flags: ui-review?(hnguyen)
Comment on attachment 8562400 [details] [review]
[PullReq] hfiguiere:bug1102481-no-result-layout to mozilla-b2g:master

Hub, the part 2 looks good to me, however, I think we should back-out the part 1 then merge part 1 and 2 together to become one patch only, or the release manager is unable to track this bug and commit, so please revert part 1 before you re-land it, thanks.
Attachment #8562400 - Flags: review?(dkuo) → review+
Assignee

Comment 24

4 years ago
Merged
https://github.com/mozilla-b2g/gaia/commit/5712ef1c6e84d962dd3a87faf4979efbad284ad5
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S6 (20feb)
Assignee

Comment 25

4 years ago
Comment on attachment 8559343 [details] [review]
[PullReq] hfiguiere:bug1102481-no-results to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no regression
[User impact] if declined: UX doesn't change
[Testing completed]: we have automated tests
[Risk to taking this patch] (and alternatives if risky): We change the search feature a but for the better.
[String changes made]: ONE string added.

Note: both patches needs to be in.
Attachment #8559343 - Flags: approval-gaia-v2.2?(bbajaj)
Assignee

Comment 26

4 years ago
Comment on attachment 8562400 [details] [review]
[PullReq] hfiguiere:bug1102481-no-result-layout to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Needed for the other patch.
[User impact] if declined: Needed for the other patch.
[Testing completed]: Automated testing.
[Risk to taking this patch] (and alternatives if risky):
[String changes made]: None in this one.

Note: this is tied to the other.
Attachment #8562400 - Flags: approval-gaia-v2.2?(bbajaj)
Assignee

Updated

4 years ago
Keywords: leave-open
waiting for ui-reviews to happen before landing on the branch.
Flags: needinfo?(jsavory)
Flags: needinfo?(hnguyen)

Updated

4 years ago
Flags: needinfo?(hnguyen)
Attachment #8562400 - Flags: ui-review?(hnguyen) → ui-review+
Assignee

Comment 28

4 years ago
Hung's review prevail Jacqueline's as she basically gave a ui-review- that I corrected with the second patch that got ui-review+.

We should be good for approval now.
Attachment #8559343 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Attachment #8562400 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Needs rebasing for v2.2 uplift.
Flags: needinfo?(hub)
Assignee

Comment 31

4 years ago
Comment on attachment 8566331 [details] [review]
[gaia] hfiguiere:bug1102481-uplift-2.2 > mozilla-b2g:v2.2

Rebased / consolidated pull request for 2.2. Carrying over 2.2 approval and reviews.
Flags: needinfo?(hub)

Comment 33

4 years ago
Posted video video.MP4
This issue has been verified successfully on Flame 2.2/3.0
STR:
1) launch "Music"
2) Scroll down to expose the "search Music" search box
3) Type in any song that is not stored in the app
4) Tap "Enter"
**A message appeared in the space and shown results that says "No music found". When taps the enter button, no action take place and the user is not taken out of the search flow.
See attachment:video.MP4
Rate:0/5

Flame 2.2 build:
Build ID               20150225002505
Gaia Revision          ca64f2fe145909f31af266b1730874051ba76c78
Gaia Date              2015-02-24 22:06:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/16804008c29f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.041814
Firmware Date          Wed Feb 25 04:18:25 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150225010244
Gaia Revision          f6bfd854fe4746f21bc006eac145365e85f98808
Gaia Date              2015-02-24 21:10:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0a8b3b67715a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150225.043702
Firmware Date          Wed Feb 25 04:37:14 EST 2015
Bootloader             L1TC00011880

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]

Updated

4 years ago
Attachment #8559343 - Flags: ui-review?(jsavory)
Sorry for the delay on the review, yes Hung's ui-review+ counts as approval.
Flags: needinfo?(jsavory)
You need to log in before you can comment on or make changes to this bug.