The search engine favicons are distorted in search preferences on Linux

VERIFIED FIXED in Firefox 34

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: FlorinMezei, Assigned: florian)

Tracking

34 Branch
Firefox 36
All
Linux
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox33 unaffected, firefox34+ verified, firefox35+ verified, firefox36+ verified, firefox37+ unaffected, firefox-esr31 unaffected)

Details

Attachments

(3 attachments)

Reproducible with Firefox 34 Beta 11 - BuildID: 20141120192249

Environment: Windows 7 x64, Windows 8 x86, Ubuntu 12.04 x86, Mac OS X 10.9.5

Steps to reproduce:
1. Open Firefox and go to Preferences -> Search.
2. See how the search engine favicons display in the list from the bottom.

Expected results:
Favicons display same as in the drop-down selector (16x16).

Actual results:
Favicons display distorted (16x14).
Blocks: fx34-searchui
No longer blocks: fx34
Florian: if this is a quick fix (Linux only?), then let's get this in too.
Assignee: nobody → florian
As this distorts our partner logos (albeit not in primary UI), I would also like to get this fix in if possible. Can this be fixed today?
Flags: needinfo?(florian)
Flags: firefox-backlog?
Assignee

Comment 3

5 years ago
Posted patch FixSplinter Review
This bug is Linux-only.

The bug is caused by the .checkbox-label-box anonymous element of the checkbox having 2px transparent borders that are caused by |-moz-appearance: checkbox-label;|, which is only set on Linux (http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/checkbox.css#40).
Flags: needinfo?(florian)
Attachment #8527833 - Flags: review?(felipc)
Attachment #8527833 - Flags: approval-mozilla-beta?
Attachment #8527833 - Flags: review?(felipc) → review+
Comment on attachment 8527833 [details] [diff] [review]
Fix

Beta+
Attachment #8527833 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Reporter

Updated

5 years ago
Flags: qe-verify+
Verified using Firefox 34.0 RC build (20141124205320) under Win 7 64-bit, Ubuntu 14.04 32-bit and Mac OSX 10.9.5.

The issue is fixed only under Ubuntu, it is still reproduced for Windows builds, see attachment.
Assignee

Updated

5 years ago
Summary: The search engine favicons are distorted in search preferences → The search engine favicons are distorted in search preferences on Linux
Assignee

Updated

5 years ago
Blocks: 1104846
Assignee

Comment 7

5 years ago
(In reply to Petruta Rasa [QA] [:petruta] from comment #6)
> Created attachment 8528383 [details]
> distortedWin.png Windows
> 
> Verified using Firefox 34.0 RC build (20141124205320) under Win 7 64-bit,
> Ubuntu 14.04 32-bit and Mac OSX 10.9.5.
> 
> The issue is fixed only under Ubuntu, it is still reproduced for Windows
> builds, see attachment.

Moving this to bug 1104846.
OS: All → Linux
Marking as Verified since remaining Windows issue was moved to a separate bug, and this was already verified as fixed for Mac and Linux.
Assignee

Updated

5 years ago
Attachment #8527833 - Flags: approval-mozilla-aurora?
Comment on attachment 8527833 [details] [diff] [review]
Fix

Approving for Aurora since this has already landed on Beta, and it's a holiday so this is the last aurora approval round before the weekend.
Attachment #8527833 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Hi Florian, can you provide a point value.
Status: NEW → ASSIGNED
Iteration: --- → 37.1
Flags: needinfo?(florian)
Flags: firefox-backlog?
Flags: firefox-backlog+
Assignee

Updated

5 years ago
Points: --- → 1
Flags: needinfo?(florian)
https://hg.mozilla.org/mozilla-central/rev/0447336d18b2
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36
Verified as fixed under Ubuntu 14.04 LTS 64-bit with Firefox 35 beta 1, Developer Edition 36.0a2 2014-12-02.
The issue is not present in Nightly 37.0a1 so I changed the status to unaffected.
You need to log in before you can comment on or make changes to this bug.