Closed Bug 11030 Opened 21 years ago Closed 21 years ago

[CRASH] Necko causes invalid page fault on modem hang-up

Categories

(Core :: Networking, defect, P3, major)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 7428

People

(Reporter: dave532, Assigned: rpotts)

Details

Overview Description: When connecting to the internet using a dial up
connection - if the connection is lost or you disconnect intentionally while a
page is loading the browser (apprunner) crashes with the following message which
pinpoints the problem to Necko:
APPRUNNER caused an invalid page fault in
module NECKO_HTTP.DLL at 0177:6038242e.
Registers:
EAX=00000000 CS=0177 EIP=6038242e EFLGS=00010246
EBX=00000000 SS=017f ESP=0063fb28 EBP=0063fbac
ECX=00000000 DS=017f ESI=092de220 FS=2927
EDX=603859a0 ES=017f EDI=00000000 GS=46ff
Bytes at CS:EIP:
8b 49 10 e8 52 f2 ff ff c2 04 00 56 8b f1 8b 46
Stack dump:
09310f60 603837a0 09310f60 007ba4b0 092d8530 00000004 602450d6 092de220 09310f60
00859150 804b000d 00000000 60244de4 092d8530 092d8534 609318ee

Steps to Reproduce:
1) Launch dial up connection
2) Start apprunner, start loading a page
3) Disconnect while page is still loading.

Actual Results:
Apprunner crashes with the message above. The crash seems to occur at the same
time the modem is hanging up.

Expected Results:
The page tries to continue loading but would be unable to. In future releases of
Mozilla their should be a dialog box warning that the network is unreachable
(like in current versions of Communicator)

Build Date & Platform Bug Found:
Build ID: 1999073108
Operating system: Windows 98 4.10.1998
Intel Pentium III / 128MB RAM

Additional Builds and Platforms Tested On:
None, as yet. I'll try with Linux if I get the chance. However at the moment the
only Linux machines I have access to have permanent net connection.

Additional Information:
Only occurs if you disconnect from an active net connection. If you disconnect
when the browser is not loading anything and then try to connect afterwards then
the browser doesn't crash, just a small error message in the text window saying
it can't load the URL.
Target Milestone: M9
Assignee: gagan → rpotts
Target Milestone: M9 → M10
Moving to m10.
david, can you check this again with 8/3 builds or later? probably is fixed.
Thanks
It actually seems to be a problem connected to the AOL software (I was running
the tests on someone elses machine, I know they pay you these days but I hate
their software).
With the 1999080408 build on Win98 disconnecting from a normal dial up
networking connection didn't recreate the bug but when using the AOL software it
crashed as before. A quick look on the about box says it's AOL version 4.0i
Revision 142.135
Surely another dupe of bug 11071.  David, the start page has been changed to
"about:blank" so this might cause you to not see it, but its still there if you
try to access a site and leave it like that for about 2 minutes.
Target Milestone: M10 → M11
connection to aol might now go through a proxy. I read something
about the switch to proxies to help loadbalance on the aol network.
wonder if that could be affecting this behavior.  add jud to cc list.
moving off to m11.

if this is no longer a problem lets close the bug.
Things are back to normal again and I'm back home and using Linux but last time
I checked I'm sure that the bug has went away. It's probably worth trying to get
someone to install AOL just to confirm it before closing the bug.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
We shouldn't crash, but dealing with the modem hang-up is another case of
needing timeouts in the socket transport (and possibly detecting the network
status).

QA: Can you verify that this doesn't crash now.

*** This bug has been marked as a duplicate of 7428 ***
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
Status: RESOLVED → VERIFIED
Yes.  Verified as a dup, thought it is 11071.
You need to log in before you can comment on or make changes to this bug.