Closed Bug 11071 Opened 21 years ago Closed 21 years ago

Crash trying to access a site with no/firewalled access.

Categories

(Core :: Networking, defect, P3)

x86
Windows 95
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: CodeMachine, Assigned: gagan)

References

Details

(Whiteboard: asked reporter)

Overview Description:

Necko Apprunner crashes after about 2 minutes.

Steps to Reproduce:

1) Start Up Apprunner
2) Wait

Actual Results:

APPRUNNER caused an invalid page fault in
module NECKO_HTTP.DLL at 0137:6038236b.
Registers:
EAX=00000000 CS=0137 EIP=6038236b EFLGS=00010246
EBX=00000000 SS=013f ESP=0063fb2c EBP=0063fbb0
ECX=00000000 DS=013f ESI=09038940 FS=0e8f
EDX=60385990 ES=013f EDI=00000000 GS=3717
Bytes at CS:EIP:
8b 49 10 e8 15 f3 ff ff c2 04 00 56 8b f1 8b 46
Stack dump:
09037f20 603836dd 09037f20 007ba9d0 09038080 00000004 602450d6 09038940 09037f20
090323e0 00000000 00000000 60244de4 09038080 09038084 609318ee

I'm using Win95( B Or C, not sure ) and have tested this on builds "99080115"
and "99072908".  No additional builds and platforms tested.

Additional Information:

It says NECKO_HHTP.  Is it attempting to do something with HTTP, say contact
Mozillazine, even though the UI doesn't show it?  I'm behind a firewall and
require a proxy, which has not been set up.

The hard drive grinds a bit, then increases to a thrash, then it dies, like
often happens with a crash.
*** Bug 11065 has been marked as a duplicate of this bug. ***
Target Milestone: M9
possibly a dup of 11015
Didn't see that one.  Looks like it might be.

Q:  Why is it trying to contact mozillazine yet neither the throbber nor the
lollipop are moving?  Is there a bug on this?
it's either a threading problem, which is talked about in the xpfe newsgroup or
an async dns lookup problem bug 10732
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I dont see the crash possibly fixed (and hence a duplicate of 11015) Marking
fixed.
Status: RESOLVED → VERIFIED
I don't see it either. Marking verified. Matty, please re-open bug if you still
see it with builds 8/3 or after.
My complements to the programmer.
Status: VERIFIED → REOPENED
Argh, spoke too soon.  I'm still seeing this when trying to _access a site_
under apprunner (1999080508).  It's just that apprunner seems to come up with
"about:blank" initially now!

Notice the similarity, it's definitely the same bug:

APPRUNNER caused an invalid page fault in
module NECKO_HTTP.DLL at 0137:6038243f.
Registers:
EAX=00000000 CS=0137 EIP=6038243f EFLGS=00010246
EBX=00000000 SS=013f ESP=0063fb2c EBP=0063fbb0
ECX=00000000 DS=013f ESI=0903e910 FS=0d27
EDX=60385478 ES=013f EDI=00000000 GS=389f
Bytes at CS:EIP:
8b 49 10 e8 a6 f2 ff ff c2 04 00 56 8b f1 8b 46
Stack dump:
0904e780 60382eec 0904e780 007b8590 0903fdd0 00000004 602450a0 0903e910 0904e780
09048240 00000000 00000000 60244dca 0903fdd0 0903fdd4 609318ee
Summary: Crash a couple of minutes after startup. → Crash trying to access a site with no/firewalled access.
New description.
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
rpotts could have fixed this with recent checkin.
can someone re-try and reopen if still a problem
Whiteboard: asked reporter
matty, let us know what you find out, thanks
I don't have ready access to a Win95 machine anymore, but on Win98 apprunner
just spins its little wheels indefinitely now.
Status: RESOLVED → VERIFIED
k, that sounds right until we have error dialogues
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.