Closed Bug 1103839 Opened 5 years ago Closed 4 months ago

[e10s] Enable the debugger tests for e10s debug builds

Categories

(DevTools :: Debugger, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ejpbruel, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [e10s-m8])

Attachments

(4 files)

Most of the debugger tests are currently enabled for e10s, but only for opt builds. The reason for this is bug 1073352, which causes most, if not all, the tests to leak in e10s debug builds.

One bug 1073352 lands, the debugger tests need to be explicitly enabled for e10s debug builds, which is what this bug is about.
Assignee: nobody → ejpbruel
Depends on: 1073352
e10s test
Blocks: e10s-tests
tracking-e10s: --- → +
Summary: Enable the debugger tests for e10s debug builds → [e10s] Enable the debugger tests for e10s debug builds
Whiteboard: [e10s-m8]
Duplicate of this bug: 1201502
Blocks: dte10s
This first patch enables 4 tests which were failing because they were using EventUtils to send mouse events to the content process.

They have been migrated to use BrowserTestUtils.

addTab in head.js as also been migrated to use BrowserTestUtils.browserLoaded.

try : https://treeherder.mozilla.org/#/jobs?repo=try&revision=cfb47f7bec4f
I removed all the skips from browser.ini and pushed to try. This attachment contains the aggregated list of all the debugger tests that failed on e10s. (43 tests total).

Missing information about Linux debug tests: e10s devtools tests are not enabled for such builds yet.
Ran local tests in e10s debug mode, with only 55 tests disabled (down from 218) and it was successful. 
(the disabled tests are more or less the ones that are in my previous attachment + some that kept failing with e10s + debug).

Try push : https://treeherder.mozilla.org/#/jobs?repo=try&revision=2a12b42b200c
Bug 1103839 - Fix dbg tests calling script in content process

Now using ContentTask.spawn instead of directly calling the child process page (see https://wiki.mozilla.org/Electrolysis/e10s_test_tips#ContentTask). 
Unskipped related tests in browser.ini 

We are down to 52 skipped tests total, with 46 related to e10s.
Try https://treeherder.mozilla.org/#/jobs?repo=try&revision=3c2331e9bffb
Depends on: 1242986
Assignee: ejpbruel → nobody
Product: Firefox → DevTools

should be done.

Status: NEW → RESOLVED
Closed: 4 months ago
tracking-e10s: + → ---
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.