Closed Bug 1242986 Opened 4 years ago Closed 3 years ago

Enable devtools e10s mochitests on Linux debug

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(e10s+, firefox53 fixed)

RESOLVED FIXED
Tracking Status
e10s + ---
firefox53 --- fixed

People

(Reporter: jdescottes, Assigned: jryans)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file, 1 obsolete file)

Currently e10s devtools mochitest suites are not enabled in Linux debug builds. 
(https://hg.mozilla.org/build/buildbot-configs/file/tip/mozilla-tests/config.py#l2651)

Could we enable them?
I think we would want this on regular trees like fx-team as well, not just try only.
Though we have no real idea whether or not anyone has greened them up, so we don't much want to just plop them down on every tree with no idea what will happen.

Traditionally, we would enable them on some twig, get them green, then enable them everywhere, but since taskcluster is unicorns pooping sugarplums while singing lullabies, perhaps we could bypass that by getting Armen to do taskcluster runs in a try push and then turn them on in the tier-2 taskcluster jobs to find out whether or not they work?
Flags: needinfo?(armenzg)
Not sugarplums but strawberries.

In any case, let's dooo it.
Assignee: nobody → armenzg
Flags: needinfo?(armenzg)
The first group (without e10s) is already running on try, fx-team, etc.

So, the second group (with e10s) is all that's needed, I believe.
Blocks: 1242943
Blocks: 1103839
OK, here's where we really stand with these jobs.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=aba896a9c4e2&filter-searchStr=devtools%20e10s&group_state=expanded

Because a bug we were running the jobs without --e10s.

If someone is available to fix these issues I can paste in here the STR with docker.
I'm assuming that :jdescottes will investigate.
Flags: needinfo?(jdescottes)
Sure, I would like to have a look at these issues.

:armenzg can you add the STRs you mentioned?
Flags: needinfo?(jdescottes) → needinfo?(armenzg)
Let's wait to look into this next week.

We believe we found a root issue in bug 1245243.
Once we fix it some of these issues will go away.

Best case scenario there's nothing to be done in here (I doubt it) but I assume some (if not all) crashes will clear up.
Depends on: 1245243
Flags: needinfo?(armenzg)
We've made progress on bug 1245243, however, the dt jobs have not changed much (We were aiming to clear some crashes due to small shared memory).

In any case, here's where we're at the moment:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=08286a17a375,eb9f9996027b&filter-searchStr=dev&group_state=expanded

The most recent push shows the 4 pushes you will need to trigger devtools jobs on try.
Revision 25554400622b allows you to skip the build and run the tests immediately. It saves about 50 minutes.
Don't use that patch if you need to make changes to the harnesses or the tests.

The try syntax is: try: -b d -p linux64_tc -u mochitest-dt -t none

Revision 809d26b228e4 allows you to use "-p linux64_tc" which saves triggering the Buildbot build.

You can also use --interactive on your push to have ssh-like and VNC-like access to the images running the tests.

Here are the steps to reproduce locally:
https://pastebin.mozilla.org/8858733

Let me know if I can explain further.
My apologies. I should have not have assigned this to myself.
Let me know if you need help scheduling these on try or reproducing locally.
Assignee: armenzg → nobody
BTW, I've been running Linux debug e10s devtools on Ash for awhile now. Mostly green with dead CPOW oranges being the most common failure mode. Same can be said for devtools e10s on other platforms, though, so not sure if that's worth holding things up over.
https://treeherder.mozilla.org/#/jobs?repo=ash&filter-searchStr=linux%20debug%20dev&group_state=expanded
I attempted to enable these in production over in bug 1275281, but they didn't stick due to a higher than expected rate of intermittent failures.
Blocks: e10s-tests, dte10s
No longer blocks: 1242943
This patch can be used for testing. You should be able to push this to Try with |try: -b d -p linux64 -u mochitest-e10s-devtools-chrome| and things will Just Work.
It looks like this is working now.  I believe I updated the patch for TC changes.

Here's a try run with 6 green attempts:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=379703766e842595d767a1afceceb9819f875139
Attachment #8756417 - Attachment is obsolete: true
Comment on attachment 8823348 [details]
Bug 1242986 - Enable linux64 debug DevTools e10s tests.

https://reviewboard.mozilla.org/r/101892/#review102286

Niiiiiiice. Will you be going through the manifests at some point and re-enabling tests disabled that way as well?
Attachment #8823348 - Flags: review?(ryanvm) → review+
(In reply to Ryan VanderMeulen [:RyanVM] from comment #17)
> Comment on attachment 8823348 [details]
> Bug 1242986 - Enable linux64 debug DevTools e10s tests.
> 
> https://reviewboard.mozilla.org/r/101892/#review102286
> 
> Niiiiiiice. Will you be going through the manifests at some point and
> re-enabling tests disabled that way as well?

After super quick skim, I did not notice any that had been disabled for only this situation, so perhaps we're okay here.  If we do find some, let's tweak in a follow up.
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d768c92253e9
Enable linux64 debug DevTools e10s tests. r=RyanVM
Summary: Enable devtools e10s mochitests on Linux debug on try machines → Enable devtools e10s mochitests on Linux debug
https://hg.mozilla.org/mozilla-central/rev/d768c92253e9
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.