34.0b1 quick filter search of large mailbox MUCH slower than 31.2.0

RESOLVED DUPLICATE of bug 1055077

Status

Thunderbird
Search
RESOLVED DUPLICATE of bug 1055077
3 years ago
3 years ago

People

(Reporter: Peter Folk, Unassigned)

Tracking

({regression})

34 Branch
x86_64
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141117202603

Steps to reproduce:

My inbox is big (61k messages).  I noticed that searching it using the quick filter bar (for eg "advantage" in From, Recipients, and Subject) on my laptop was slow (90s) but desktop fast (4s).


Actual results:

I eliminated GLODA as a possible cause of the problem, and then realized I was on the beta channel on my laptop, but release on desktop.  I downgraded my laptop to release and the searches became fast again (4s).  Upgrading again to beta returned the problem.


Expected results:

Quick filter performance should be as fast or faster in beta =)

Comment 1

3 years ago
Could you somehow try if this is the same as bug 1055077?
(Reporter)

Comment 2

3 years ago
I could imagine they are the same, but I don't know how I would actually verify that.

Comment 3

3 years ago
Maybe by seeing if your beta build is from after the time bug 858337 had landed.
You could also try a build from after 2014-10-14 that has speed improvements in this area from bug 1005413.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1055077
You need to log in before you can comment on or make changes to this bug.