Closed Bug 1103891 Opened 7 years ago Closed 3 years ago

[Settings]The progress bar can't be dragged before you tap the play button in "Manage Ringtones" page.

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: wangxin, Unassigned)

References

Details

Attachments

(2 files)

[1.Description]:
[Woodduck2.0][Flame][2.0&2.1&2.2]When you first time drag(not tap play first) the music progress bar in "Manage Ringtones" page, you can see the progress bar can't be dragged.
Attachment log: "logcat_1700.txt" and "bugreport_1700.txt"
Attachment video: 1700.MP4
Found Time:17:00

[2.Testing Steps]: 
Prism: There are some music in device.
1. Launch "Settings".
2. Choose "Sound "item.
3. Tap "Manage Ringtones" button.
4. Press "+" icon.
5. Tap one music.
6.  Drag the progress bar.
**You can see the progress bar can‘t be dragged.
7. Tap the "Play" button.
8. Drag the progress bar.
**You can  drag the progress bar successfully.

[3.Expected Result]: 
Step6: The progress bar can be dragged successfully.

[4.Actual Result]: 
Step6:The progress bar can‘t be dragged.

[5.Reproduction build]: 
Flame2.0 Build:
Gaia-Rev        124c2f85f1b956e9e8429dab5121de702a3bc197
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/6b59dd2837c1
Build-ID        20141123000206
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141123.032645
FW-Date         Sun Nov 23 03:27:00 EST 2014
Bootloader      L1TC00011880

Flame2.1 Build:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141123.035029
FW-Date         Sun Nov 23 03:50:40 EST 2014
Bootloader      L1TC00011880

Flame2.2 Build:
Gaia-Rev        c5bad6d78c5fe168e3bb894fc5cb70902c9b19b1
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/c9cfa9b91dea
Build-ID        20141123040209
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141123.082659
FW-Date         Sun Nov 23 08:27:14 EST 2014
Bootloader      L1TC00011880

Woodduck Bulid
Gaia-Rev        3a98f1287fa7b604891220ba5d86982ae8f9971e
Gecko-Rev       03d3ab62d5b07b915434f2d1d68495ad5915ecd2
Build-ID        20141120103003
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1416391964
FW-Date         Wed Nov 19 18:12:54 CST 2014

[6.Reproduction Frequency]: 
Always Recurrence
TCID:Free Test
Attached video Bug video: 1700.MP4
Component: Gaia::Settings → Gaia::Music
Hi Mike,
This issue still exists on latest Woodduck 2.0 and Flame 2.0/2.1/2.2,
Flame2.0 build
Gaia-Rev        01c32dcdc08b3c8fc8b3082870439fa2c1089f4f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b41c344ed82d
Build-ID        20141225000210
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.033048
FW-Date         Thu Dec 25 03:30:58 EST 2014
Bootloader      L1TC00011880

Flame 2.1 :
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141225001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.035108
FW-Date         Thu Dec 25 03:51:19 EST 2014
Bootloader      L1TC00011880

Flame 2.2:
Gaia-Rev        ab41c35eed35404b632a4841714b81b56364ba32
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2acb12da9813
Build-ID        20141225010202
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.043916
FW-Date         Thu Dec 25 04:39:27 EST 2014
Bootloader      L1TC00011880

Woodduck 2.0 build:
Gaia-Rev        add38992bbfb2bafca52ac1ce7f6231ac702675f
Gecko-Rev       8d951d9c4988e218ec08c6118a35c7faeb70af49
Build-ID        20141225143517
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1419478053
FW-Date         Thu Dec 25 11:27:57 CST 2014
Flags: needinfo?(mlien)
since this is a general issue, remove confidential

Hi SandKing, where do you get the expected result that progress bar should be enabled to drag?

Hi Dominic, is this audio control is by design?
Group: woodduck-confidential
Flags: needinfo?(wangxin)
Flags: needinfo?(mlien)
Flags: needinfo?(dkuo)
Hi Mike,
There is no TC for reference, I think this may be an issue after discussion with Norry.
Flags: needinfo?(wangxin)
This is probably by design but it's due to the implementation, before we actually start the previewing, the music player won't start decoding the audio file, and that's why you can see the duration is still ---:-- and the progress bar is unseekable. We should be able to adjust this to make it seekable before the first play, let's needinfo ux to confirm this.

Jacqueline, am I correct on this? thanks.
Flags: needinfo?(dkuo) → needinfo?(jsavory)
Sorry for the delay here, I definitely think that if we can change this to make it possible to seek prior to the first time play we should do it.
Flags: needinfo?(jsavory)
Duplicate of this bug: 1136847
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.