[Flame]You can launch the App that is covered by soft home button bar.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: wangxin, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8527578 [details]
Bug video:video_2355.mp4

[1.Description]:
[Flame][v2.1][Homescreen]You can launch the App that be covered by soft home button bar via tapping black space of soft home button bar.

Found time:23:55
Attch:logcat_2355.txt ,video_2355.mp4

[2.Testing Steps]: 
1.Enable soft home button via setting >developer.
2.Back to home screen.
3.Slide screen to make APP icon be covered by soft home button bar.
4.Tap  black space of soft home button bar.

[3.Expected Result]: 
4. No APP should  be launched.

[4.Actual Result]: 
4.You can launch the App that is covered by soft home button bar.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        afdfa629be209dd53a1b7b6d6c95eab7077ffcd9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/dc3018cbdbe6
Build-ID        20141123001201
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8527586 [details]
Bug log:logcat_2355.txt

Comment 2

4 years ago
This issue dose not exist on Flame 2.2:
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/57e4e9c33bef
Build-ID        20150103010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150103.045144
FW-Date         Sat Jan  3 04:51:56 EST 2015
Bootloader      L1TC000118D0
(Reporter)

Comment 3

4 years ago
Created attachment 8545144 [details]
Verified log: logcat_1719.txt

Hi Eric,
 This issue still exists on latest Flame2.0&2.1&2.2 and Woodduck2.0
Found time: 17:19

Flame 2.0 build:
Gaia-Rev        f76014fd2c7528493b90d759c68ec3070233d094
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/aedeb9e38bb9
Build-ID        20150106000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.034857
FW-Date         Tue Jan  6 03:49:08 EST 2015
Bootloader      L1TC000118D0

Flame 2.1 build
Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID        20150106001308
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.034709
FW-Date         Tue Jan  6 03:47:20 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2a193b7f395c
Build-ID        20150106010234
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150106.043413
FW-Date         Tue Jan  6 04:34:26 EST 2015
Bootloader      L1TC000118D0

Woodduck 2.0 build:
Gaia-Rev        06b544f8a9ee03754dd3f5020f279cffa7a75804
Gecko-Rev       6b1e24a1cba1d5542bebb503ce05a1ec61ceb7d3
Build-ID        20150107050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1420578377
FW-Date         Wed Jan  7 05:06:46 CST 2015
Flags: needinfo?(echang)
(Reporter)

Updated

4 years ago
Blocks: 1054172, 1080481
Group: woodduck-confidential
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.2: --- → affected
We can skip testing on Software home button for the moment since this is currently for dev use only.
Flags: needinfo?(echang)

Comment 5

3 years ago
2.5+ as Z3C uses software homebutton.
Group: woodduck-confidential
blocking-b2g: --- → 2.5+
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected

Comment 6

3 years ago
There's nothing the homescreen can do about this, sounds like a bug in system or possibly in platform if occluded elements are receiving touch events.
Component: Gaia::Homescreen → Gaia::System::System UI
Summary: [Flame][Homescreen]You can launch the App that is covered by soft home button bar. → [Flame]You can launch the App that is covered by soft home button bar.

Updated

3 years ago
status-b2g-v2.5: affected → ---

Comment 7

3 years ago
soft home button only for dev mode and not blocking issue here.
Status: NEW → RESOLVED
blocking-b2g: 2.5+ → ---
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.