[FFOS] seek in OmxDecoder will not end If the length of first seeked frame is 0

RESOLVED FIXED in Firefox OS v2.0M

Status

()

Core
Audio/Video
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: bwu, Assigned: bwu)

Tracking

unspecified
mozilla37
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 unaffected, b2g-v2.0M fixed, b2g-v2.1 unaffected, b2g-v2.2 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

3 years ago
Some codecs output a first frame with length = 0 right after seeking, in current OmxDecoder seek design [1], it will make seek not end in a while loop. 

[1]http://dxr.mozilla.org/mozilla-central/source/dom/media/omx/OmxDecoder.cpp?from=OmxDecoder.cpp#596
(Assignee)

Updated

3 years ago
Blocks: 1102123
blocking-b2g: --- → 2.0M?

Updated

3 years ago
blocking-b2g: 2.0M? → 2.0M+
status-b2g-v2.0M: --- → affected

Updated

3 years ago
Blocks: 1054172, 1080337
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → unaffected

Updated

3 years ago
Blocks: 1090125
(Assignee)

Comment 1

3 years ago
Created attachment 8528283 [details] [diff] [review]
Bug-1104411-Continue-reading-frame-if-the-length-is-.patch

Continue reading frame if the length of frame is 0 when seeking.
(Assignee)

Comment 2

3 years ago
Hi Wayne,

Could you please help test the patch (attachment 8528283 [details] [diff] [review]) to see if it can work or not?
Thanks a lot!
Flags: needinfo?(waychen)
(Assignee)

Comment 3

3 years ago
I have tested it on my Flame. It can work well.
bwu, isn't this bug affect to b2gv2.0?
Flags: needinfo?(bwu)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1102123
(Assignee)

Comment 6

3 years ago
The problem mentioned in comment 0 currently only happen on the platform in Bug 1054172 and cannot be seen in Flame 2.0. 
In the attached patch, I am trying to have a solution for all platforms with different codec behavior. 
Not sure if other platforms in the future will also hit this problem. We may need to check in to 2.0 as well besides 2.0m if there is no other concerns.
(Assignee)

Updated

3 years ago
Flags: needinfo?(bwu)
Hi Blake,

It works in woodduck.
Flags: needinfo?(waychen)
(Assignee)

Comment 8

3 years ago
Thanks a lot! Wayne
(Assignee)

Comment 9

3 years ago
Created attachment 8528760 [details] [diff] [review]
Bug-1104411-Continue-to-read-next-frame-if-the-lengt.patch

Add some comments to attachment 8528283 [details] [diff] [review].
Attachment #8528283 - Attachment is obsolete: true
Attachment #8528760 - Flags: review?(sotaro.ikeda.g)

Updated

3 years ago
Blocks: 1094102
Comment on attachment 8528760 [details] [diff] [review]
Bug-1104411-Continue-to-read-next-frame-if-the-lengt.patch

Looks good!
Attachment #8528760 - Flags: review?(sotaro.ikeda.g) → review+
(Assignee)

Comment 12

3 years ago
Created attachment 8529731 [details] [diff] [review]
Master-Bug-1104411-Continue-to-read-next-frame-if-the-lengt.patch

1. Carry r+ from sotaro.
2. Rebase attachment 8528760 [details] [diff] [review] to Master branch.
Attachment #8529731 - Flags: review+
(Assignee)

Comment 13

3 years ago
Created attachment 8529739 [details] [diff] [review]
(2.0m)Bug-1104411-Continue-to-read-next-frame-if-the-lengt.patch

1. Carry r+ from sotaro.
2. Clear the commit message.
Attachment #8528760 - Attachment is obsolete: true
Attachment #8529739 - Flags: review+
(Assignee)

Comment 14

3 years ago
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=2b4aa8341ca9 
Testing result looks good!

Please check in attachment 8529731 [details] [diff] [review] to master branch.
Keywords: checkin-needed
(Assignee)

Comment 15

3 years ago
Hi seinlin,

Please help check in attachment 8529739 [details] [diff] [review] to 2.0M branch if no concerns.
Thanks!
Flags: needinfo?(kli)
https://hg.mozilla.org/mozilla-central/rev/0b338c05b865
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37

Updated

3 years ago
Blocks: 1107999

Updated

3 years ago
status-b2g-v2.0M: affected → fixed
status-b2g-v2.2: unaffected → fixed

Updated

3 years ago
Priority: -- → P1

Updated

3 years ago
No longer blocks: 1107999
You need to log in before you can comment on or make changes to this bug.