javascript strict warnings in EditorPublish.js

VERIFIED DUPLICATE of bug 88208

Status

VERIFIED DUPLICATE of bug 88208
17 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: cmanske)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Warning: reference to undefined property gDialog.SiteList
Source File: chrome://editor/content/EditorPublish.js
Line: 295

Warning: reference to undefined property gDialog.PageTitleInput
Source File: chrome://editor/content/EditorPublish.js
Line: 289

Warning: reference to undefined property gDialog.TabPanels
Source File: chrome://editor/content/EditorPublish.js
Line: 335

build 20011115

Updated

17 years ago
Target Milestone: --- → M1

Updated

17 years ago
Target Milestone: M1 → Future

Comment 1

17 years ago
This happens in a debug build by doing what?
Status: NEW → ASSIGNED
(Reporter)

Comment 2

17 years ago
start Compose
select File -> Publish -> Publish

remember to have js strict warnings set to on via prefs -> debug
I think the three above strict JS warnings are no longer in effect.  Note in
http://lxr.mozilla.org/seamonkey/source/editor/ui/dialogs/content/EditorPublish.js
lines 50, 55, and 57.

In build Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.7+) Gecko/20020105 I get:

Warning: test for equality (==) mistyped as assignment (=)?
Source File: chrome://editor/content/EditorPublish.js
Line: 160, Column: 26
Source Code:
          if (len = urlLen)

Patch for this strict warning coming up.
Created attachment 63704 [details] [diff] [review]
patch for comparison instead of assignment strict warning
Adding patch keyword as I cannot check this in.
Keywords: patch

Comment 6

17 years ago
brade: can you take a look at Alex's patch?

Comment 7

17 years ago
Comment on attachment 63704 [details] [diff] [review]
patch for comparison instead of assignment strict warning

r=brade
Attachment #63704 - Flags: review+

Comment 8

17 years ago
-->cmanske who has this change in his tree already
Assignee: syd → cmanske
Status: ASSIGNED → NEW
Target Milestone: Future → ---
(Assignee)

Comment 9

17 years ago
Yep, I have this in my latest work for bug 88208

*** This bug has been marked as a duplicate of 88208 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
v
Status: RESOLVED → VERIFIED

Comment 11

17 years ago
Henrik, can you test this out using 3/8 build...fix for 88208 went
into this build, so you should not see this problem anymore..

Please verify...and REOPEN this bug if you still see the problem..thanks!
(Reporter)

Comment 12

17 years ago
v dupe. I cant get any strict warn anymore...
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.