Closed Bug 1104919 Opened 5 years ago Closed 5 years ago

[Browser][Statusbar] When opening a link, the rocketbar gets expanded, but the statusbar is still minimized

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 verified)

VERIFIED FIXED
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- verified

People

(Reporter: apastor, Assigned: apastor)

Details

(Keywords: verifyme, Whiteboard: [systemsfe])

Attachments

(1 file)

It's easier to notice when enabling as many icons as possible (NFC, debug, etc)

STR:

1.- Open the Browser
2.- Minimize the Rocketbar
3.- Click on a Top Site

Expected:

When the rocketbar expands, we see the statusbar maximized

Actual

The statusbar is shown minimized

The statusbar
The main issue I see here is that the icon that shows if we are transferring data (we do when loading a webpage) is not shown. Also, this will become a bigger issue (we won't see any statusbar) as soon as bug 1074332 lands.
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → apastor
Attachment #8529020 - Flags: review?(mhenretty)
Comment on attachment 8529020 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26479

Looks good. I'm going to take the liberty of merging this now so I can get it into my master QA build.
Attachment #8529020 - Flags: review?(mhenretty) → review+
master: https://github.com/mozilla-b2g/gaia/commit/38a3c612bf09bbf481f3a6781e33b0820f77ad3f
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Verified the issue is fixed on 2.2 

All icons are appear on the status bar when switching from minimized rocketbar to expanded one

"Flame 2.2
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (Unknown)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
"
The issue DOES REPRO on 2.1

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141201001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  "

The statusbar is shown minimized when the "Rocketbar" is expanded 
==================================================================
Adding "verifyme" for 2.1 uplift
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.