[Utility Tray] Status Bar icons toggle off/on to soon

RESOLVED FIXED

Status

Firefox OS
Gaia::System
P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: epang, Assigned: albertopq)

Tracking

({polish})

unspecified
x86
Gonk (Firefox OS)
polish
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [systemsfe], ux-most-wanted-nov2014, 2x-uxnom)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8496983 [details]
Ambient_Indicator_Tray_opening_flow.jpg

Hi Alberto,

I'm opening this bug as a follow up to bug 1067913.
Currently with the patch in bug 1067913 the status bar icons toggle off before the handle passes with the vice versa happening when the tray goes up.

I've attached a visual flow of what ideally should happen.
If you have any questions please let me know, thanks!
Duplicate of this bug: 1094459
blocking-b2g: --- → backlog
Priority: -- → P1
(Reporter)

Updated

4 years ago
Blocks: 1098041
(Assignee)

Comment 2

4 years ago
Created attachment 8523812 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26189

Eric, could you please ui-review this?

Thanks!
Attachment #8523812 - Flags: ui-review?(epang)
Blocks: 994991
Whiteboard: [systemsfe] → [systemsfe], ux-most-wanted-nov2014
(Reporter)

Comment 3

4 years ago
Comment on attachment 8523812 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26189

Hey Alberto, this is looking really good but I think a few tweaks are needed.

1. Is it possible to have the handle of the utility tray full opaicty all the way though?  I think it will help with the transition.

2.  When pulling down the handle at the top it feels a little jagged. Right after you see the entire handle it feels like it snaps down.  Is there anything we can do to make this smoother?

3. When you close the tray the date/icons shouldn't move up.  It looks cool, but the icons end up flashing back that are under the tray.  This only happens when you you flick the tray closed - if you hold you're finger down it doesn't happen.

Let me know if you have any questions or if I need to clarify :).  This is looking great so far!!  Flag more for review again when ready and feel free to bug me!
Flags: needinfo?(apastor)
Attachment #8523812 - Flags: ui-review?(epang) → ui-review-
(Assignee)

Comment 4

4 years ago
Comment on attachment 8523812 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26189

Hi Eric. I just updated the patch, and now 1 and 3 should be fixed. Regarding 2, couldn't find an easy way of making it smoother (we are showing/hiding the real statusbar when that happens, so moving only in that space is not cheap). I'll ask for advice on the review for that.

Thanks!
Flags: needinfo?(apastor)
Attachment #8523812 - Flags: ui-review- → ui-review?(epang)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8523812 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26189

This is great, thanks for working on this Alberto :).  It also seems pretty smooth to me - have you updated the patch since yesterday? R+
Attachment #8523812 - Flags: ui-review?(epang) → ui-review+
(Assignee)

Updated

4 years ago
Attachment #8523812 - Flags: review?(mhenretty)
Comment on attachment 8523812 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26189

Looking real good on the phone! I had a couple of questions on github, please reflag me when you answer/address those.
Attachment #8523812 - Flags: review?(mhenretty)
(Assignee)

Updated

4 years ago
Blocks: 1107244
Duplicate of this bug: 1094506
Whiteboard: [systemsfe], ux-most-wanted-nov2014 → [systemsfe], ux-most-wanted-nov2014, 2x-uxnom
(Assignee)

Comment 8

4 years ago
Comment on attachment 8523812 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26189

I updated the PR with some fixes and also replied to the comments. Could you please re-check? Thanks!
Attachment #8523812 - Flags: review?(mhenretty)
Comment on attachment 8523812 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/26189

Looks good! Left a couple of tiny comments on github. Also, we should probably have an integration test for protecting the statusbar icon states when toggling the utility tray.
Attachment #8523812 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 10

4 years ago
Added integration tests and fixed comments.

master: https://github.com/mozilla-b2g/gaia/commit/8654a14cd4a790484603fded2566367eca6cbeb6
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Backed out for making test_quick_settings.py permafail on OSX.
Master: https://github.com/mozilla-b2g/gaia/commit/3d72b41ba36829fd5f37ad8d076a6af45b9ad6ee

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=1002619&repo=b2g-inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

4 years ago
Sorry, everything was green when I checked in:

https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=180beee9b5b3

I'll take a look. Thanks!
Looks like the failure rate is ~40% based on the retriggers I've done.
(Assignee)

Comment 14

4 years ago
Relanded with tests fix:

master: https://github.com/mozilla-b2g/gaia/commit/a1ec2268e7b467aa0ff07a2a3cbd1b9abc4e4dd1
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1113404
Depends on: 1115047
Depends on: 1114764
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.