Closed Bug 1105059 Opened 8 years ago Closed 8 years ago

Plugin rendering position lags behind correct position when scrolling with apz on

Categories

(Core :: Panning and Zooming, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1157708

People

(Reporter: mitchell, Unassigned)

References

Details

Reproduction:

1. Visit http://www.air-trekkers.com/
2. Ensure flash is enabled and video is playing.
3. Scroll.

While most of the page scrolls smoothly, the flash video hangs around in its old position for too long, and only slowly catches up.
Blocks: 1086162
Component: General → Panning and Zooming
Product: Firefox → Core
Version: 36 Branch → Trunk
Was this with apzc on Windows? (Which I don't think actually work yet.) Or is this just a general bug? What version of the browser are you using? Do you have e10s enabled?
Sorry, I forgot my buildstring - Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141125030206 CSet: 74edfbf0e6a3

Yes, apz + tiling on win8.1x64. It does indeed work now! Yes, e10s is enabled.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can see this even on sites without flash.
For example, all full width pictures on the following site are flickering:
http://www.bbc.com/future/bespoke/story/20150430-rosetta-the-whole-story/index.html#taking-shape-8027
This is only happening with APZ on.
I think comment 3 is a different bug, has to do with background-attachment:fixed which is what the bbc page uses. I'll file a separate bug for it.
I filed bug 1166301 with a reduced test case for comment 3. This bug appears to be a dupe of bug 1157708, so duping.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1157708
You need to log in before you can comment on or make changes to this bug.