Status

MailNews Core
Backend
P3
normal
VERIFIED DUPLICATE of bug 91702
19 years ago
4 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

({helpwanted})

Trunk
x86
Windows 2000
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

This means allowing access to mail messages and headers from
the MAPI API or sending mail from a MAPI app through Messenger. This is
not related to using a MAPI mail client with Navigator.
Whiteboard: HELP WANTED
Target Milestone: M15
marking m15

Updated

19 years ago
QA Contact: lchiang → ppandit

Updated

19 years ago
Blocks: 12185

Comment 2

19 years ago
Bulk-resolving requests for enhancement as "later" to get them off the Seamonkey
bug tracking radar. Even though these bugs are not "open" in bugzilla, we
welcome fixes and improvements in these areas at any time. Mail/news RFEs
continue to be tracked on http://www.mozilla.org/mailnews/jobs.html

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 3

19 years ago
reopening to re-assign

Updated

19 years ago
Resolution: LATER → ---

Comment 4

19 years ago
Great :-)
I'll just clear the LATER resolution here.

Updated

19 years ago
Assignee: phil → cwhite7
Status: REOPENED → NEW

Comment 5

19 years ago
Reopen mail/news HELP WANTED bugs and reassign to nobody@mozilla.org

Updated

19 years ago
Assignee: nobody → cwhite7

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Blocks: 15280

Updated

19 years ago
Blocks: 15281

Updated

19 years ago
Keywords: helpwanted

Comment 6

19 years ago
Chris, anything happening with this?
Summary: [HELP WANTED]Simple MAPI → Simple MAPI
Whiteboard: HELP WANTED
Target Milestone: M15

Comment 7

19 years ago
Not much progress has been made, going to re-assign to nobody so that I am not 
sitting on these issues.  Will probably pick up again in a month or two if they 
are still open issues when I have time and I can actually make some progress 
first.
Assignee: cwhite7 → nobody
Status: ASSIGNED → NEW

Comment 8

18 years ago
Nominating for mozilla1.0 - often-requested feature.
Keywords: mozilla1.0
*** Bug 62790 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
 This breaks many other applications that use mail. If Mozilla is your only mail
client, you are hosed. In particular, Groove (www.groove.net) needs this.

Comment 11

18 years ago
Because Mozilla does not support Simple MAPI yet, the mail-related application
we are developing will not be Mozilla compatible.

Comment 12

18 years ago
I fail to see how anyone can use Mozilla or Netscape 6. All sorts of mail link 
functionality breaks here. People (you developer typre!) are worried about 
nonsense such as the chromes, while important, basic functionality is missing. 
Only in recent builds can one actually file a new bookmark!
Later is not a good answer for this bug.

Comment 13

18 years ago
4xp = this feature was in Netscape 4.x, Outlook (Express), Pegasus and probably
any other mailer on the win32 platform.

nsCatFood = this causes problems for people who want their application to
interact with mail. This makes it impossible for people to use Mozilla
exclusively as their mail client if they require such features.
Keywords: 4xp, nsCatFood

Updated

17 years ago
Keywords: nsenterprise
Setting URL to 
http://developer.netscape.com/docs/manuals/communicator/mapisupp.htm - a 
document that was used for adding Simple MAPI to NS4
After furthur research it appears we should be using CMC API instead of Simple
MAPI. CMC (common messenging calls) API is newer and cross platform.
There is a bit more information at http://www.dorn.org/uni/mapi/cmc.html

Looking at the IE's Internet Settings, mozilla should be included under Mail,
News and Address Book. If this bug does not cover those areas then a new bug
should be created to fix them.
Summary: Simple MAPI → CMC API support (similar to Simple MAPI)

Comment 16

17 years ago
Ian, if you are interested in having CMC support added, perhaps you should file 
a new bug as an RFE.   I'm changing the Summary back to the original one, since 
that's what this bug is about.

CMC is totally different than Simple MAPI, and I am not aware of any programs 
which support it, offhand.   All mail programs I know of on Win32 support 
Simple MAPI...   it's the standard in the Win32 world.

CMC is also no longer supported by Microsoft.
http://support.microsoft.com/support/kb/articles/Q262/7/01.ASP#Common
Summary: CMC API support (similar to Simple MAPI) → Simple MAPI
hmm, if CMC support is not present in other applications then there is no point
in adding it.

Is there an alternative to Simple MAPI on unix/mac?

Comment 18

17 years ago
Not that I am aware of, unfortunately.  (at least on the unix/linux end)  I'm 
not so sure about mac...  I hear that there are Simple MAPI mac apps, but I 
cannot verify this.

It would be nice if there was some sort of XP standard for this kind of thing, 
but it's just not the way it is.

This is pretty much a Win32-only issue/enhancement, but I think it's important, 
especially since 4.x has this support.

Comment 19

17 years ago
netscape had a mail api which people kinda used. there's a bug somewhere about 
it. (Third-Party Mail and News Client [postal.h] search devedge.)

Comment 20

17 years ago
re: second comments From Ian Thomas 2001-05-31 09:12
77846 All your internet properties should belong to us 

Updated

17 years ago
Blocks: 77846

Comment 21

17 years ago
Umm since this Windows only why the All/All? Setting to PC/Win2k
OS: All → Windows 2000
Hardware: All → PC

Comment 23

17 years ago
Would anyone have any objection to my making this a dup of 91702?  I know this
bug came first but that bug already has a lot of the people who have volunteered
to work on it.

Comment 24

17 years ago
why not do it the other way round? This bug is blocking other bugs already, it
will cause lots of spam.

Comment 25

17 years ago
As long as it is fixed, I do not care what you call it. Just move the list of 
names to the other bug.

Comment 26

17 years ago
Doing the honors for Scott, marking this duplicate of 91702.

*** This bug has been marked as a duplicate of 91702 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 27

17 years ago
verified duplicate
Status: RESOLVED → VERIFIED
*Updating:
-(B) '12185, 15280, 15281, 77846', as duplicate.
No longer blocks: 12185, 15280, 15281, 77846
Product: MailNews → Core
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.