Libpurple proxy preferences are broken

RESOLVED FIXED in 1.6

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: aleth, Assigned: aleth)

Tracking

({regression})

Details

(Whiteboard: [1.6-blocking])

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
STR

1) Try to enter proxy details, and try to click OK: This fails.
00:17:49 - Fearful: Error: NS_ERROR_XPC_BAD_CONVERT_JS: Could not convert JavaScript argument arg 0 [purpleICoreService.globalProxy]
00:17:52 - Fearful: Source File: chrome://instantbird/content/proxies.js
00:17:54 - Fearful: Line: 169

2) Try to click on one of the other two options for the proxy settings, and try to click OK: This also fails.
Timestamp: 28/11/2014 00:25:20
Error: NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [purpleICoreService.getProxies]
Source File: chrome://instantbird/content/proxies.js
Line: 50
Timestamp: 28/11/2014 00:25:37
Error: NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [purpleICoreService.globalProxy]
Source File: chrome://instantbird/content/proxies.js
Line: 163
(Assignee)

Comment 1

5 years ago
This patch fixes 1)
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8531304 - Flags: review?(clokep)
(Assignee)

Comment 2

5 years ago
Fixes 2). It is possible for the purpleCoreService not to be already initialized if there are no libpurple accounts and the account wizard has not been opened.
Attachment #8531322 - Flags: review?(clokep)
Attachment #8531304 - Flags: review?(clokep) → review+
(Assignee)

Comment 3

5 years ago
Attachment #8531322 - Attachment is obsolete: true
Attachment #8531322 - Flags: review?(clokep)
Attachment #8531346 - Flags: review?(clokep)
Attachment #8531346 - Flags: review?(clokep) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Updated

5 years ago
Attachment #8531304 - Attachment description: proxyfix.diff → Part 1 - purplexpcom [already checked in]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.6
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Thanks for taking a look at this! :)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 955736
You need to log in before you can comment on or make changes to this bug.