Closed Bug 1106136 Opened 8 years ago Closed 8 years ago

Crash Report [@ js::jit::LiveInterval::addRangeAtHead(js::jit::CodePosition, js::jit::CodePosition) ] on Yandex maps

Categories

(Core :: JavaScript Engine: JIT, defect)

37 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: phazon, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20141128080044

Steps to reproduce:

1) Go at http://apteka.ru/sankt-peterburg/map/
2) Wait map to load, push several times on "+" button (zoom) in map area
3) wait a little or move (drag) map


Actual results:

Crash.
Got several crash reports one after one (was performing update) each time
https://crash-stats.mozilla.com/report/index/bp-b737be71-ae5d-48d4-879b-c48242141128
https://crash-stats.mozilla.com/report/index/bp-af832255-6d87-4d79-9de2-00f7b2141128
https://crash-stats.mozilla.com/report/index/bp-01afc535-a71f-4ab7-abfe-e0cd12141128
each time same rash info.


Expected results:

Page should load normally, zoom should not cause crash.

I did not taken risk to report this in https://bugzilla.mozilla.org/show_bug.cgi?id=1073431 or https://bugzilla.mozilla.org/show_bug.cgi?id=1072691
Looks like this bug isn't related to solely Apteka.ru, but rather Yandex.maps itself - pretty same result on http://maps.yandex.ru
https://crash-stats.mozilla.com/report/index/3d2e20dc-57ca-4119-abed-780bf2141128
Summary: Crash Report [@ js::jit::LiveInterval::addRangeAtHead(js::jit::CodePosition, js::jit::CodePosition) ] on apteka.ru map page → Crash Report [@ js::jit::LiveInterval::addRangeAtHead(js::jit::CodePosition, js::jit::CodePosition) ] on Yandex maps
Yandex.maps crashes on my Linux machine too. If I double click on the map to zoom in, *boom* Firefox dies.
Another test case is to simply load <http://www.standtanning.com/The_Fitzpatrick_Skin.pdf>, which consistently crashes with a similar stack (on my Mac):

https://crash-stats.mozilla.com/report/index/8db6ba39-c1a7-4729-9ac5-166932141129
Status: UNCONFIRMED → NEW
Component: Untriaged → JavaScript Engine: JIT
Ever confirmed: true
OS: Linux → All
This could be the same issue as bug 1105543.
Bisecting on mozilla-central gives the regression range 20141124100136 - 20141125030206:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=be4ba3d5ca9a&tochange=74edfbf0e6a3

..which includes bug 1093674, so it seems likely this (like bug 1105543) is a regression from that landing.
Blocks: 1093674
Crash Signature: [@ js::jit::LiveInterval::addRangeAtHead(js::jit::CodePosition, js::jit::CodePosition)]
Keywords: crash, regression
With Firefox Nightly Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0 i dont encounter crashes anymore. 
http://maps.yandex.ru loading normally, even heavy interacting with map cause no crash.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.