Closed Bug 1106349 Opened 5 years ago Closed 5 years ago

TEST-UNEXPECTED-FAIL | /builds/slave/test/build/tests/xpcshell/tests/toolkit/components/search/tests/xpcshell/test_selectedEngine.js

Categories

(Thunderbird :: Search, defect)

defect
Not set

Tracking

(thunderbird35 fixed, thunderbird36 fixed)

RESOLVED FIXED
Thunderbird 37.0
Tracking Status
thunderbird35 --- fixed
thunderbird36 --- fixed

People

(Reporter: hiro, Assigned: hiro)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

04:42:31 INFO - TEST-PASS | /builds/slave/test/build/tests/xpcshell/tests/toolkit/components/search/tests/xpcshell/test_selectedEngine.js | test_defaultEngine - [test_defaultEngine : 69] true == true
04:42:31 INFO - PROCESS | 21345 | *** Search: _buildSortedEngineList: building list
04:42:31 INFO - Unexpected exception NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getComplexValue]
04:42:31 INFO - getDefaultEngineName@/builds/slave/test/build/tests/xpcshell/tests/toolkit/components/search/tests/xpcshell/test_selectedEngine.js:47:9
04:42:31 INFO - test_defaultEngine@/builds/slave/test/build/tests/xpcshell/tests/toolkit/components/search/tests/xpcshell/test_selectedEngine.js:89:50
04:42:31 INFO - _run_next_test@/builds/slave/test/build/tests/xpcshell/head.js:1241:9
04:42:31 INFO - do_execute_soon/<.run@/builds/slave/test/build/tests/xpcshell/head.js:512:9
04:42:31 INFO - _do_main@/builds/slave/test/build/tests/xpcshell/head.js:184:5
04:42:31 INFO - _execute_test@/builds/slave/test/build/tests/xpcshell/head.js:372:5
04:42:31 INFO - @-e:1:1 

Thunderbird in US region is going to switch Yahoo or continue to use Bing?
Fix for this issue depends on the default engine.
Attached patch bug1106349.patchSplinter Review
We need those preferences regardless of those values.

https://treeherder.mozilla.org/ui/#/jobs?repo=try-comm-central&revision=2d00e7a8c1e0
Attachment #8530605 - Flags: review?(mkmelin+mozilla)
(In reply to Hiroyuki Ikezoe (:hiro) from comment #0)
> Thunderbird in US region is going to switch Yahoo or continue to use Bing?
> Fix for this issue depends on the default engine.

AFAIK thunderbird has its own search deal, so at least there's no direct switch.
Assignee: nobody → hiikezoe
Comment on attachment 8530605 [details] [diff] [review]
bug1106349.patch

Review of attachment 8530605 [details] [diff] [review]:
-----------------------------------------------------------------

Thx, Hiro!
Attachment #8530605 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/4de62824831f
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
Target Milestone: Thunderbird 38.0 → Thunderbird 37.0
Same test failure is reported on comm-aurora. What is the Thunderbird policy regarding test failure on non-trunk branches? Should test fixes be ported back?
Yes, it should be uplifted.
Comment on attachment 8530605 [details] [diff] [review]
bug1106349.patch

[Approval Request Comment]
Regression caused by (bug #): 1102416
User impact if declined: test failure due to m-c changes
Testing completed (on c-c, etc.): working on trunk
Risk to taking this patch (and alternatives if risky):
Attachment #8530605 - Flags: approval-comm-aurora?
Attachment #8530605 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8530605 [details] [diff] [review]
bug1106349.patch

[Triage Comment]
Looks like we also want this on beta.
Attachment #8530605 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.