Open Bug 1106626 Opened 5 years ago Updated 3 months ago

Ability to add custom search engines by URL (non open-search and non-amo engines)

Categories

(Firefox :: Search, defect, P3)

defect

Tracking

()

REOPENED

People

(Reporter: ntim, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxsearch])

It'd be nice to be able to add engines from their url, for engines that don't use opensearch, or that aren't available on amo. Chrome allows this in their search engine manager.
Bug 261124 - Textbox context menu should have "Add to Search Bar..."
There is a (oldish) patch in that bug.

Also see: https://addons.mozilla.org/addon/add-to-search-bar/
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 261124
Bug 261124 will allow adding search engines from textboxes, but not from URLs. About a third of my bookmark keywords have no corresponding <form>:

* Twitter search [all, not just 'top tweets']
* Twitter username
* Subreddit name
* Unicode codepoint
* DXR search with 'path:webidl'

I've also had to edit many of bookmarks manually, when the site moves from http to https or changes in a way that breaks my searches.

In bug 648398 comment 5, Philipp Sackl suggests this should be an addon, rather than part of the built-in UI for managing search engines. So maybe this is WONTFIX, but it's not quite a dup of bug 261124.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Ability to add custom search engines (non open-search and non-amo engines) → Ability to add custom search engines by URL (non open-search and non-amo engines)
Blocks: 648398
Priority: -- → P3
Whiteboard: [fxsearch]
Rank: 35
We should implement this by showing something similar to our RSS feed dialog when you navigate directly to a search XML.

IT should show information about the engine and have a button to add it.
(In reply to Mike Kaply [:mkaply] from comment #3)
> [...]
> when you navigate directly to a search XML.

Which is a nice idea as a separate bug, but not really applicable here, because here you won't necessarily even have a search XML in the first place.

What's needed is something (a separate dialogue, or directly within the search engine list, or whatever) that lets you enter a title, a query URL with %s/%S, optionally a keyword and for bonus points even an icon and then creates a custom search engine based on that.
> What's needed is something (a separate dialogue, or directly within the search engine list, or whatever) that lets you enter a title, a query URL with %s/%S, optionally a keyword and for bonus points even an icon and then creates a custom search engine based on that.

We kind of already have that.

Any entry field that does a search can be added a search engine. Just long click on the entry field and you'll get an "add search engine" option.
Which doesn't work for things that aren't available via search entry fields, though, since that dialogue doesn't offer any way of editing the resulting search URL. E.g. I have a search keyword for Bugzilla bugs that goes directly via show_bug.cgi=%s instead of buglist.cgi?quicksearch=%s and more importantly, some custom Wikipedia searches that prepend/append some words to my search query to save on typing when looking at certain types of articles that always start/end with the same words, i.e. similar to the things mentioned in comment 2.

At the moment this doesn't matter since the search created by that dialogue ends up as a keyword search "bookmark" anyway which I can edit manually, but if bug 648398 goes ahead that possibility would no longer be there, as the search engine manager currently doesn't offer any way of editing a search plugin's internal data, i.e. most importantly the query URL.
when keywords will go away there will be a way to create and edit custom search engines.
Is this planned in the near future? Seem like a simple addition, so why not look into adding it?

I've had to mess with HTML on sites with the dev tools to add fake <form> tags in order to get the "Add to search bar" menu to popup.
Blocks: 1503551
Duplicate of this bug: 1336604
You need to log in before you can comment on or make changes to this bug.