Closed Bug 1336604 Opened 3 years ago Closed 4 months ago

Allow customized search engines to be set as default

Categories

(Firefox :: Search, defect)

52 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1106626

People

(Reporter: gwmfms6, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Steps to reproduce:

Tried to add custom search engine as default engine


Actual results:

Firefox does not offer an easy way to do this.


Expected results:

Users should be able to take a simple URL string (e.g., https://duckduckgo.com/?kn=1&q=%s) and make this the default search engine. Users used to be able to do this by adding engines to the searchplugins folder but this no longer works.
Hi, this is an enhancement?
Component: Untriaged → Search
Flags: needinfo?(gwmfms6)
It seems a dupe of bug 1326446, or bug 1195005, or others as bug 648398, if that approach will be the chosen one.
(In reply to ovidiu boca[:Ovidiu] from comment #1)
> Hi, this is an enhancement?

I am not sure what you mean by "enhancement"? I view it as a requirement for using a web-browser. I want to be able to use a URL-parameter search engine (e.g., https://duckduckgo.com/?kn=1&kac=-1&kae=d&q=%s) as my default search engine. So if I go to the URL-Awesome-bar or the Search-bar and type something then the https://duckduckgo.com/?kn=1&kac=-1&kae=d&q=%s search engine is the one that is used to process the search.

Here is the process I go through in adding a custom search engine in Google Chrome and Firefox:

### Google Chrome
Settings > Manage search engines > Location: https://duckduckgo.com/?kn=1&kac=-1&kae=d&q=%s > Keyword: DDG > click on the "Make default" button 

[now if I go to the URL-bar and type something the search is run through https://duckduckgo.com/?kn=1&kac=-1&kae=d&q=%s


### Firefox
Ctrl+Shift+O (Show All Bookmarks) > Organize > New Bookmark > Location: https://duckduckgo.com/?kn=1&kac=-1&kae=d&q=%s > Keyword: DDG > NO WAY TO MAKE THIS THE DEFAULT SEARCH ENGINE 

[now if I go to the URL-bar and type something, my just added search engine is only used if I preface the search with DDG. How do I make https://duckduckgo.com/?kn=1&kac=-1&kae=d&q=%s the DEFAULT engine so I do NOT have to preface searches with DDG?
Flags: needinfo?(gwmfms6)
Duplicate of this bug: 1326446
A bug is marked as an enhancement when it contains suggestions or ideas to improve Firefox.
This bug is a regression.

This functionality used to exist in Firefox when users could add search engines to the "searchplugins" folder (on linux at): /home/$USER/.mozilla/firefox/<gv6krt1c.default>/searchplugins

Mozilla removed the functionality of the searchplugins folder but provided no alternative way to make a custom search engine the default search engine. This bug is a high priority for me as it determines what search engine I can use.
You can create a search engine from a XML file as indicated in bug 1236498 comment 7, or with some add-ons.

You can set any of your search engines as the default, whatever its origin or install process, from about:preferences.
Carlos, I don't understand your statement: "You can set any of your search engines as the default, whatever its origin or install process, from about:preferences."

The gist of my bug report is that I can not set "any" of my search engines as the default; I can only set certain ones (e.g., those which are one-off engines). I cannot set my URL-parameter created DuckDuckGo engine as the default engine. Are you saying there is a way to do this at about:preferences? If so, could you explain how?
(In reply to Greg from comment #8)
> I cannot set my URL-parameter created DuckDuckGo engine as the
> default engine.

Because that is not a search engine; as you mention in comment 3, that is a bookmark with a keyword set: they can be used in a engine-like way from the urlbar, but these are bookmarks first: they aren't accesible from the search bar, and they can't be managed from about:preferences#search. These two Firefox things are usually confused with each other: the reason that bug 648398 exists. 

You can to move your bookmarks-with-keywords to be real search engines using, by example, [1] or [2], and then manage them in the same way as the search engines shipped by default.


[1]: https://addons.mozilla.org/firefox/addon/search-engine-creator/
[2]: https://addons.mozilla.org/firefox/addon/search-engines-export-import/
Having to install an extension to do this is ridiculous. I'm not even trying to get the parameter to "be" a search engine.

Just letting you guys know that what I'm bringing up here is a problem that needs solving. I should be able to set the parameter I'm talking about as the default URL-bar search so a "keyword" does not have to entered for searches. This didn't even used to be a problem and only became one with the introduction of those one-off engines.

The idea here is effectively the same as what is described in bug 1106626, and interconnected with bug 648398. I'm going to mark this as duplicate as I don't think there's benefit in keeping this open as well.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1106626
You need to log in before you can comment on or make changes to this bug.