[Status bar] The status bar icons are overlapping the "rocket bar" search when an URL address is entered from the minimized rocketbar

VERIFIED WORKSFORME

Status

defect
VERIFIED WORKSFORME
5 years ago
4 years ago

People

(Reporter: sarsenyev, Assigned: apastor)

Tracking

({polish, regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-exploratory-1][systemsfe], )

Attachments

(1 attachment)

Reporter

Description

5 years ago
Posted file log12114.txt
Description:
When entering an URL address in the "rocketbar" when the "rocketbar" is minimized, the status bar icons are overlapping while the URL page is opens
  
Prerequisites:
Five icons are displayed on the status bar,(NFC, WIFi, Adb tools, Bluetooth)

Repro Steps:
1) Update a Flame device to BuildID: 20141201040205
2) Open "Browser"
3) Scroll down to see the Minimize the "Rocket bar" 
4) While the "Rocketbar: is still minimized enter an "URL address" and hit enter

Notes: YouTube video is attached
  
Actual:
During transition the icons are overlapping the status bar(see YouTube video)
  
Expected: 
No overlapping appears
  
Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141201040205
Gaia: 39214fb22c203e8849aaa1c27b773eeb73212921
Gecko: 08be3008650f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro frequency: 100%

See attached: (logcat, YouTube link)
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.2-exploratory-1]
Reporter

Comment 1

5 years ago
The bug was found on Flame 2.2 device, Master (319mb)(Kitkat Base)(Full Flash)

The issue doesn't repro on 2.1
 
No overlapping occurs when opening a webpage from minimized "rocketbar"

"Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


This future is not implemented on 2.0
  "
"Flame 2.0

Device: Flame 2.0
Build ID: 20141201000201
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: c756bd8bf3c3
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0"
Removing the 2.0 tracking flag, as the feature was not yet implemented. Not nominating to block on this because  the status bar is still visible, and the overlap will go away within a short amount of time
Flags: needinfo?(dharris)
Keywords: regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
blocking-b2g: --- → 2.2?
Whiteboard: [2.2-exploratory-1] → [2.2-exploratory-1][systemsfe]
Can we get a regression window?
QA Contact: jmercado
blocking-b2g: 2.2? → 2.2+
Keywords: polish
Bug 1104919 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141126112726
Gaia: 9f07b0fa04e79732f1314d58e38b637eb04ccee9
Gecko: aad95dbcd8ad
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141126115825
Gaia: 9ec3033b2f83983f778c85143182d51b35387eee
Gecko: 0602e8509d68
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - 
Gaia: 9f07b0fa04e79732f1314d58e38b637eb04ccee9
Gecko: 0602e8509d68

First Broken gaia / Last Working gecko - 
Gaia: 9ec3033b2f83983f778c85143182d51b35387eee
Gecko: aad95dbcd8ad

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/9f07b0fa04e79732f1314d58e38b637eb04ccee9...9ec3033b2f83983f778c85143182d51b35387eee
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Putting on Albertos radar.
Flags: needinfo?(apastor)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: jmercado
Assignee

Updated

5 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Assignee

Comment 6

5 years ago
I cannot repro this issue. Some patches landed lately for the statusbar, so this issue might be already fixed. Adding qawanted to double check.
Keywords: qawanted
QA Contact: bzumwalt
Unable to repro issue on latest PVT Flame 2.2 Master

After 7 attempts with Headphone, Debug, Bluetooth, Data transfer, Cell signal, WiFi, Battery, and Time icons in status bar, these icons do not overlap the rocketbar search bar when a URL address is entered from minimized rocketbar in browser.


Device: Flame 2.2 Master
BuildID: 20150105010205
Gaia: c2bf20d23851d5fda9f8f0ef0267db5f49152376
Gecko: 636498d041b5
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
Resolving as WFM, please re-open if you see this happening still.
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Resolution: --- → WORKSFORME
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
cannot reproduce anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.