Closed Bug 1106818 Opened 5 years ago Closed 5 years ago

[Video] Volume buttons do not function in app permission page of youtube video

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, firefox37 wontfix, firefox38 wontfix, firefox39 fixed, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S7 (6mar)
blocking-b2g 2.2+
Tracking Status
firefox37 --- wontfix
firefox38 --- wontfix
firefox39 --- fixed
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: SalvadorR, Assigned: dwi2, NeedInfo)

References

()

Details

(Keywords: regression, Whiteboard: [2.2-exploratory-1])

Attachments

(2 files, 1 obsolete file)

Description:
When user is in app permission page to put a youtube video in full screen, the volume button will not function at all on the page.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141202040207
2) Go to youtube and play a video
3) Put the youtube video in full screen mode and an app permission page will appear
4) Attempt to change the volume with the volume keys in the app permission page
5) Observe Volume functionality

Actual:
Volume button has no functionality
  
Expected: 
Volume appears properly
  
Environmental Variables:
Device: Flame 2.2 (319mb) KK Full Flash
BuildID: 20141202040207
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 2c9781c3e9b5
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Notes: Volume bar also does not appear when pressing volume keys
  
Repro frequency: 5/5
See attached: Video, Logcat
http://youtu.be/0yw5n8J9Ans
This issue does not occur on Flame 2.0 and 2.1

Results: Volume has functionality

Flame 2.0

Device: Flame 2.0
Build ID: 20141201000201
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: c756bd8bf3c3
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141202001201
Gaia: ccb49abe412c978a4045f0c75abff534372716c4
Gecko: 18fb67530b22
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

The volume buttons do not function at all. Basic functionality is broken. Also a regression. Nominating to block on 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Component: Gaia::Video → AudioChannel
Flags: needinfo?(dharris)
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20141107104406
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: f2a91c7332be
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141107173411
Gaia: 5f8206bab97cdd7b547cc2c8953cadb2a80a7e11
Gecko: 84df30ea5121
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: 84df30ea5121
Broken Gaia / Working Gecko = Repro
Gaia: 5f8206bab97cdd7b547cc2c8953cadb2a80a7e11
Gecko: f2a91c7332be
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/779f05fead3d009f6e7fe713ad0fea16b6f2fb31...5f8206bab97cdd7b547cc2c8953cadb2a80a7e11


B2G Inbound
Last working
BuildID: 20141107024412
Gaia: 3ca3172b9122fedf46c8411e92c48b724104aae5
Gecko: 45b2fb3afbce
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141107030312
Gaia: 940d52127168dc694882967ccae37f6e294c9566
Gecko: 60cc0b101ce9
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 3ca3172b9122fedf46c8411e92c48b724104aae5
Gecko: 60cc0b101ce9
Broken Gaia / Working Gecko = Repro
Gaia: 940d52127168dc694882967ccae37f6e294c9566
Gecko: 45b2fb3afbce
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/3ca3172b9122fedf46c8411e92c48b724104aae5...940d52127168dc694882967ccae37f6e294c9566
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Broken by patch for Bug 1014418 - can you take a look Tzu-Lin?
Blocks: 1014418
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(tzhuang)
QA Contact: ckreinbring
System app could not receive any key events or mozbrowserbefore/after keydown/keyup events after step 3.
I need Gina's help on checking Gecko side.

Also, I noticed that:
when video plays in fullscreen mode at step 3, just tap screen again to make control panel appears, then system app could receive key events as usual and volume buttons work normally.
Flags: needinfo?(tzhuang) → needinfo?(gyeh)
Flags: needinfo?(gyeh)
Here are my observations. When application requests fullscreen, focus window is set to shell.html (http://dxr.mozilla.org/mozilla-central/source/b2g/chrome/content/shell.js#472). Thus, the event target of volume keys is body of shell.html resulting in neither System App nor App like youtube receive key event.

Vivien, I've checked bug 728373 but I'm not sure that there is any reason for now to keep it? Any suggestion?
Flags: needinfo?(21)
Depends on AudioChannel refactoring. Fix this when new AudioChannel complete.
blocking-b2g: 2.2? → ---
Depends on: NewAudioChannel
Hi Evan,

Please look this bug. Thanks.
Flags: needinfo?(evanxd)
Hi Steven,

I'll take a look.
But this is not a blocker, I'll do it after I finish other higher priority tasks.
Flags: needinfo?(evanxd)
I strongly suggest we fix this issue earlier because it obviously causes focus lost issue on non-touch screen device. It seems the focus never goes back to content after leaving full-screen mode. On non-touch screen device like TV, the lost focus can't be recovered unless reboot. 

Assign to dwi2.
Assignee: nobody → tzhuang
I think it's a focus issue, not AudioChannel bug.
Component: AudioChannel → General
Hi Fabrice,

This patch removes everything from bug 728373. There is no reason to keep this workaround because now we always have 'mozbrowserbeforekeydown'/'mozbrowserbeforekeyup' sent to shell.html. And also the focus is important especially on non-touch device as comment 10 stated.

Please help to review the patch, thanks
Attachment #8571903 - Flags: review?(fabrice)
Attachment #8571903 - Flags: review?(fabrice) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a4eca7eedb48
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S7 (6mar)
Duplicate of this bug: 1150462
Nominate 2.2? because bug 1150462 is 2.2+ already and it is duplicated bug of this.
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Please request b2g37 approval on this patch when you get a chance.
Flags: needinfo?(tzhuang)
Comment on attachment 8572409 [details] [diff] [review]
Patch 1: Stop moving focus to shell.html when receiving mozfullscreenchange, r=fabrice

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Hardware key is malfunction when device is playing video in full screen
Testing completed: 
Risk to taking this patch (and alternatives if risky): No
String or UUID changes made by this patch: No
Flags: needinfo?(tzhuang)
Attachment #8572409 - Flags: approval-mozilla-b2g37?
Attachment #8572409 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
This issue is verified fixed on Flame Master and 2.2.

Result: The volume control works properly on the fullscreen permission screen.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150421010201
Gaia: a8e4f95dce9db727dda5d408b038f97fb4296557
Gecko: 7b823253d9f2
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150421002501
Gaia: 828dd03a0e3b140d74b2e49355197df4d91d9227
Gecko: 36f72a3efb9b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.