Firefox Hello cog/gear sub-menu remains open until you mouse over it (even if you close top-level menu!), and then aggressively closes when you mouse out of it

RESOLVED DUPLICATE of bug 1084291

Status

Hello (Loop)
Client
RESOLVED DUPLICATE of bug 1084291
4 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STR:
 1. Open Firefox Hello menu.
    (If all you see is "Getting started", click that, & re-open the menu)

 2. Click the Cog/Gear icon in the bottom-right.

 3. Hit "esc" key, or alt-tab, or something else to make the Hello menu be dismissed.

 4. Re-open the Hello menu.

ACTUAL RESULTS: The cog/gear submenu is still open.

EXPECTED RESULTS: The cog/gear submenu should be closed, when you re-open the Hello menu. (It feels bizarre that the submenu's openness persists, through the top-level menu being closed.)


Overall, the submenu's closing behavior feels unintuitive to me -- after you've opened it, it appears to remain open indefinitely (including inside of a closed top-level menu, as noted above in STR/actual-results) -- it remains open *until* you mouseover it, and *then* it aggressively closes as soon as your cursor moves off of it.
(Reporter)

Updated

4 years ago
Summary: Firefox Hello cog/gear sub-menu remains open until you mouse over it (even if you close top-level menu!, and then aggressively closes when you mouse out of it → Firefox Hello cog/gear sub-menu remains open until you mouse over it (even if you close top-level menu!), and then aggressively closes when you mouse out of it
(Reporter)

Comment 1

4 years ago
Created attachment 8531469 [details]
screencast

(Here's a screencast showing the sub-menu persisting even through top-level-menu-closing, until you mouse-over it, and then it eagerly closing as soon as the cursor moves off of it.)
(Reporter)

Comment 2

4 years ago
Version info: Nightly 37.0a1 (2014-12-02)
Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Ubuntu 14.10
backlog: --- → Fx37?

Updated

4 years ago
backlog: Fx37? → Fx38?

Updated

3 years ago
backlog: Fx38? → ---
This has been improved in recent versions. There's only one remaining issue as far as I know, which is the menu stays open when you close via clicking on the loop button and then reopen without focusing anywhere else. That's covered by bug 1084291, so duping this there.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1084291
You need to log in before you can comment on or make changes to this bug.