Closed Bug 1107210 Opened 5 years ago Closed 5 years ago

Conversation Name doesn't update in the panel when changing it in the room preview

Categories

(Hello (Loop) :: Client, defect, P1)

defect
Points:
2

Tracking

(firefox35+ unaffected, firefox36 fixed, firefox37 fixed)

RESOLVED FIXED
mozilla37
Iteration:
37.1
Tracking Status
firefox35 + unaffected
firefox36 --- fixed
firefox37 --- fixed
Blocking Flags:
backlog Fx35+

People

(Reporter: standard8, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

STR:

1) Create a new room
2) In the room preview, enter a name for the room, press enter or tab
3) Open the panel

Expected Results

- The panel displays the new name

Actual Results

- The panel displays the original name
[Tracking Requested - why for this release]: Not correctly updating the UI in the new rooms code. Confusing to the user as to why a rename might not have happened.
backlog: --- → Fx35+
Priority: -- → P1
Comment on attachment 8531714 [details] [diff] [review]
Fixed room name update not correctly reflected in Loop panel.

Is there some way we can/should test this?
Added unit test.
Attachment #8531714 - Attachment is obsolete: true
Attachment #8531714 - Flags: review?(standard8)
Attachment #8532109 - Flags: review?(standard8)
Attachment #8532109 - Flags: review?(standard8) → review+
https://hg.mozilla.org/integration/fx-team/rev/75fe9fbfe722
Iteration: --- → 37.1
Points: --- → 2
Target Milestone: --- → mozilla37
https://hg.mozilla.org/mozilla-central/rev/75fe9fbfe722
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Comment on attachment 8532109 [details] [diff] [review]
Fixed room name update not correctly reflected in Loop panel.

Approval Request Comment
[Feature/regressing bug #]: Rooms

[User impact if declined]: Not correctly updating the UI in the new rooms code. Confusing to the user as to why a rename doesn't happen.

[Describe test coverage new/current, TBPL]: Includes test; plus manual test.  On m-c

[Risks and why]: Very simple, low-risk patch that affects only loop rooms

[String/UUID change made/needed]: none
Attachment #8532109 - Flags: approval-mozilla-beta?
Attachment #8532109 - Flags: approval-mozilla-aurora?
Attachment #8532109 - Flags: approval-mozilla-beta?
Attachment #8532109 - Flags: approval-mozilla-beta+
Attachment #8532109 - Flags: approval-mozilla-aurora?
Attachment #8532109 - Flags: approval-mozilla-aurora+
After getting approvals and uplifting to Aurora, I noted that this bug actually depends on (fixes issues with) bug 1090173, which we did not ask for beta/35 approval for.  So I held off on uplifting this.

Removing checkin-needed, and probably we should mark this wontfix for 35
Depends on: 1090173
Keywords: checkin-needed
>Removing checkin-needed, and probably we should mark this wontfix for 35
Actually, it would be more accurate to mark this "unaffected" for Fx35 since Bug 1090173 was not uplifted to Fx35.
Attachment #8532109 - Flags: approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.