Closed Bug 1090173 Opened 8 years ago Closed 8 years ago

As a user, from the Panel, I should be able to rename a room

Categories

(Hello (Loop) :: Client, defect, P1)

x86
All
defect
Points:
3

Tracking

(firefox36 fixed, firefox37 fixed)

RESOLVED FIXED
mozilla37
Iteration:
36.3
Tracking Status
firefox36 --- fixed
firefox37 --- fixed
backlog Fx36+

People

(Reporter: shell, Unassigned)

References

Details

(Whiteboard: [rooms][strings])

User Story

As a desktop client user I want to be able to rename a room from within the panel so that I can identify the room in the room list.

Attachments

(1 file, 1 obsolete file)

No description provided.
backlog: --- → Fx36?
Whiteboard: [rooms] → [rooms][strings]
P1 to at least land the strings - if the bug is simple - let's get this in.
backlog: Fx36? → Fx36+
Priority: -- → P1
Assignee: nobody → nperriault
Points: --- → 3
Postponed, we should rather focus on fx35+ stuff atm.
Assignee: nperriault → nobody
The string to add is "Click to edit room name"
Depends on: 1105537
Assignee: nobody → nperriault
Comment on attachment 8529778 [details] [diff] [review]
Allow to rename a room from Loop panel.

Review of attachment 8529778 [details] [diff] [review]:
-----------------------------------------------------------------

This is good, and I like it. One issue though:

- When I click on the form to edit, it highlights the existing name (that's fine).
- If I then click again (e.g. to put the cursor in somewhere), then it submits the form and opens the room.

It'd be nice if I am clicking on the input field for it to not submit/open the room - obviously outside that area would be a submit (though it'd also be nice if it didn't open the room when you're edit mode and click anywhere else on the panel).

::: browser/components/loop/ui/fake-mozLoop.js
@@ +53,5 @@
>    getLoopPref: function(pref) {
>      // Ensure UI for rooms is displayed in the showcase.
>      if (pref === "rooms.enabled") {
>        return true;
> +    } else if (pref === "gettingStarted.seen") {

I think you could just do:

if (pref === "rooms.enabled" ||
    pref === "gettingStarted.seen") {
Attachment #8529778 - Flags: review?(standard8) → review-
Comment on attachment 8529928 [details] [diff] [review]
Allow to rename a room from Loop panel. Patch v2

Review of attachment 8529928 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=Standard8
Attachment #8529928 - Flags: review?(standard8) → review+
https://hg.mozilla.org/mozilla-central/rev/ff920f2cebfb
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: mozilla36 → mozilla37
Comment on attachment 8529928 [details] [diff] [review]
Allow to rename a room from Loop panel. Patch v2

Approval Request Comment
[Feature/regressing bug #]: rooms

[User impact if declined]: Can't rename a room from the room panel, only from within the room

[Describe test coverage new/current, TBPL]: Includes tests, on central

[Risks and why]: Low risk as functionality already existed, and still exists.  Not uplifting to Beta since the strings required landed in 36.  Landed on fxteam before aurora uplift but didn't merge to central in time.

[String/UUID change made/needed]: none (already landed/uplifted in patch 1).
Attachment #8529928 - Flags: approval-mozilla-aurora?
Attachment #8529928 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: in-testsuite+
Duplicate of this bug: 1107833
You need to log in before you can comment on or make changes to this bug.