Closed Bug 1107259 Opened 6 years ago Closed 6 years ago

Remove the sync IPC getDPI() and getDefaultScale() during app startup (~15ms).

Categories

(Firefox OS Graveyard :: Performance, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.2+)

RESOLVED FIXED
2.2 S2 (19dec)
feature-b2g 2.2+

People

(Reporter: fabrice, Assigned: fabrice)

References

Details

Attachments

(1 file)

Attached patch getdpi.patchSplinter Review
This is technically a subset of 835679. This patch sends dpi and defaultScale in the SendShow() call along with other initialization data.
Attachment #8531730 - Flags: review?(tlee)
No longer blocks: 1094010
Summary: Remove the sync IPC getDPI() and getDefaultScale() during app startup. → Remove the sync IPC getDPI() and getDefaultScale() during app startup (~15ms).
Comment on attachment 8531730 [details] [diff] [review]
getdpi.patch

Review of attachment 8531730 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/ipc/TabParent.cpp
@@ +2028,5 @@
>      widget = nsContentUtils::WidgetForDocument(mFrameElement->OwnerDoc());
>    }
>  
>    if (widget) {
> +    printf_stderr("XXX TryCacheDPIAndScale parent=%p widget=%p\n", this, widget.get());

Do you remove this debug message?

::: widget/gonk/nsWindow.cpp
@@ +557,5 @@
>  
>  float
>  nsWindow::GetDPI()
>  {
> +    printf_stderr("XXX gonk nsWindow::GetDPI() %p\n", this);

Do you remove this debug message?
Attachment #8531730 - Flags: review?(tlee) → review+
Duplicate of this bug: 835679
https://hg.mozilla.org/mozilla-central/rev/beac475d3863
Assignee: nobody → fabrice
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S2 (19dec)
Depends on: 1111957
feature-b2g: --- → 2.2?
feature-b2g: 2.2? → 2.2+
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
You need to log in before you can comment on or make changes to this bug.