[gonk-l] can not detcet SIM card

RESOLVED DUPLICATE of bug 1112175

Status

Firefox OS
RIL
RESOLVED DUPLICATE of bug 1112175
3 years ago
3 years ago

People

(Reporter: askeing, Assigned: edgar)

Tracking

unspecified
2.2 S2 (19dec)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(feature-b2g:2.2+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Can not detect SIM card.

STR:
1. insert SIM card into Nexus 5.
2. power on.
3. open Settings app.

Expected:
Can detect SIM card.

Actual:
Can not detect SIM card.

Comment 1

3 years ago
Looks like something we need to work on 2.2.
feature-b2g: --- → 2.2?
2.2+ as it blocks the L porting
feature-b2g: 2.2? → 2.2+
(Assignee)

Updated

3 years ago
Assignee: nobody → echen
(Assignee)

Comment 3

3 years ago
Created attachment 8537765 [details]
[log] gonk_l_can_not_dectect_SIM_card.log
(Assignee)

Comment 4

3 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #3)
> Created attachment 8537765 [details]
> [log] gonk_l_can_not_dectect_SIM_card.log

From the log I didn't see gecko try to fetch sim card state, I guess it is why no sim card detected.
(Assignee)

Comment 5

3 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #4)
> (In reply to Edgar Chen [:edgar][:echen] from comment #3)
> > Created attachment 8537765 [details]
> > [log] gonk_l_can_not_dectect_SIM_card.log
> 
> From the log I didn't see gecko try to fetch sim card state, I guess it is
> why no sim card detected.

Hmm, gecko didn't receive `RIL_UNSOL_RIL_CONNECTED`, have no idea yet.
(Assignee)

Comment 6

3 years ago
Okay, I did not see rild in process list. And I got below error when I try to launch it manually:

--
WARNING: linker: could not load library "libsigchain.so" from LD_PRELOAD for "/system/bin/sh"; caused by library "libsigchain.so" not found
WARNING: linker: could not load library "libsigchain.so" from LD_PRELOAD for "rild"; caused by library "libsigchain.so" not found
open: Permission denied
 Diag_LSM_Init: Failed to open handle to diag driver, error = 2
--
(Assignee)

Comment 7

3 years ago
Probably related to bug #1112175, I will try the patch in bug #1112175 to see if it brings the rild back.
(Assignee)

Comment 8

3 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #7)
> Probably related to bug #1112175, I will try the patch in bug #1112175 to
> see if it brings the rild back.

Confirm that the patch in bug #1112175 fixes this. I will mark as this bug as a duplicated of bug #1112175 once it is landed.
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Hardware: All → ARM
Resolution: --- → DUPLICATE
Duplicate of bug: 1112175

Updated

3 years ago
Target Milestone: --- → 2.2 S2 (19dec)
You need to log in before you can comment on or make changes to this bug.