[e10s] Scroll amount doubles when enabling Electrolysis

RESOLVED DUPLICATE of bug 1153156

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 1153156
3 years ago
2 years ago

People

(Reporter: akulle12, Unassigned)

Tracking

37 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
When having the Electrolysis feature enabled the amount of pixels scrolled from a single click of the mouse wheel doubles.
(Reporter)

Updated

3 years ago
Blocks: 516752

Comment 1

3 years ago
This happens for me on win32 trunk builds on Win8.1 x64.

Comment 2

3 years ago
Is it reproducible on Win 7 or others OSes?
Component: Untriaged → Widget: Win32
akulle12, can you please copy and paste your about:support information into this bug? Just open Help menu > Troubleshooting Information menu item > "Copy text to clipboard" button.
tracking-e10s: --- → ?
(Reporter)

Comment 4

3 years ago
For some reason the about:support page just shows up like this...
Application Basics
------------------

Name:
Version:
User Agent:
Multiprocess Windows:

Crash Reports
-------------

Extensions
----------

Graphics
--------

Important Modified Preferences
------------------------------

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC:

Accessibility
-------------

Activated:
Prevent Accessibility:

Library Versions
----------------

Experimental Features
---------------------


I opened my Firefox Developer Edition that uses a different profile than my Nightly and it worked fine. I hope this helps although it's not the Nightly build in which the bug occurs.


Application Basics
------------------

Name: Firefox
Version: 36.0a2
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0
Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-953b0e6e-aeb5-417d-b797-ff1452141209
Submitted: 23 hours ago

All Crash Reports

Extensions
----------

Name: ADB Helper
Version: 0.7.1
Enabled: true
ID: adbhelper@mozilla.org

Name: Firefox Developer Tools Adapters
Version: 0.2.2
Enabled: true
ID: fxdevtools-adapters@mozilla.org

Graphics
--------

Adapter Description: AMD Radeon HD 7520G
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID: 0x9990
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17111)
Driver Date: 11-20-2014
Driver Version: 14.501.1003.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 1849103c
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 7520G Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 4
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20141210004006
browser.startup.homepage_override.buildID: 20141210004006
browser.startup.homepage_override.mstone: 36.0a2
dom.mozApps.used: true
extensions.lastAppVersion: 36.0a2
gfx.direct3d.last_used_feature_level_idx: 0
media.gmp-gmpopenh264.lastUpdate: 1415203892
media.gmp-gmpopenh264.version: 1.1
media.gmp-manager.lastCheck: 1418134606
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1418134608
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.npctrl: 0
plugin.state.npgoogleupdate: 0
plugin.state.npvlc: 0
plugin.state.npwlpg: 0
privacy.cpd.offlineApps: true
privacy.cpd.siteSettings: true
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1415797795

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.7
Version in use: 4.10.7

NSS
Expected minimum version: 3.17.3 Basic ECC
Version in use: 3.17.3 Basic ECC

NSSSMIME
Expected minimum version: 3.17.3 Basic ECC
Version in use: 3.17.3 Basic ECC

NSSSSL
Expected minimum version: 3.17.3 Basic ECC
Version in use: 3.17.3 Basic ECC

NSSUTIL
Expected minimum version: 3.17.3
Version in use: 3.17.3

Experimental Features
---------------------
tracking-e10s: ? → +

Comment 5

3 years ago
I like e10s, it works really well now but this bug makes it really annoying.
Duplicate of this bug: 1158799

Comment 7

3 years ago
Same here. Arch GNU/Linux. How come is this in "UNCONFIRMED" state?

Comment 8

3 years ago
I'm experiencing this also, but it's not just e10s that prompts it. I also get double scroll length when I enalble APZ without e10s.
Here are the customizations (copied from bug 1158799):

I have 15 lines set in windows' mousewheel settings.

I have these customizations that affect scrolling in firefox:
user_pref("toolkit.scrollbox.horizontalScrollDistance", 16);
user_pref("toolkit.scrollbox.verticalScrollDistance", 12);
general.smoothScroll.lines.durationMaxMS", 450);
user_pref("general.smoothScroll.lines.durationMinMS", 450);
user_pref("general.smoothScroll.mouseWheel.durationMinMS", 400);
user_pref("general.smoothScroll.pages.durationMaxMS", 385);
user_pref("general.smoothScroll.pages.durationMinMS", 385);
Fairly sure that this is a duplicate, duping forward since the other bug is clearer.

For those of you on operating systems other than Windows file a new bug. The solution is platform dependent.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158424
I think you duped it to the wrong bug.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(kbrosnan)
Resolution: DUPLICATE → ---
Late night bugzilla'ing :(
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(kbrosnan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1153156
No longer blocks: 516752
tracking-e10s: + → ---
You need to log in before you can comment on or make changes to this bug.