Closed Bug 1109014 Opened 6 years ago Closed 2 years ago

Revert FF 34 to remember last used search engine like before

Categories

(Firefox :: Search, defect)

34 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: gtimur, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

Change search engine from the search bar.


Actual results:

Before FF 34: changing search engine was remembered and default was "last  used"
From FF 34: there is explicit default search engine and last used is not remembered


Expected results:

Expected behavior: "last  used" search engine is still accessible for subsequent searches
Proposed solution: add  "last  used" to the list of search engines in "Choose your default search engine"
Component: Untriaged → Search
I'm going to call this a duplicate of bug 1109851, since the use case seems the same.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1109851
I revert back to Unconfirmed for 3 reasons:
- bug 1109851 is more complicated, demanding different issues
- it's been almost 2 years since that one is not even defined, mentioning some additional problems
- if this one, clearly defined, is resolved, that can help bug 1109851

So, please confirm, hoping that someone will just revert this behavior to how it was.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
OS: Windows 7 → All
Hardware: x86_64 → All
Is there a workaround for this? For me this is a blocker, I'm still on FF 38 ESR because of this and because 45 ESR doesn't allow this previous search bar style.

The workaround for this would be to right-click the search engine and set it as default until you want to change it.

After 5 years, I don't see us reverting this behaviour, especially with it not seeming to be a common complaint. I understand this may be frustrating, unfortunately we can't support every possible use case.

I'm going to close this out as I don't think it is worth tracking at this stage.

Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.