Closed Bug 1109292 Opened 5 years ago Closed 5 years ago

Volume control for HTML5 Audio in Windows XP SP3 controls global wav output volume

Categories

(Core :: Audio/Video, defect)

35 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1092859

People

(Reporter: crazymonkee, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached file test_audio.html
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141108040201

Steps to reproduce:

Using Firefox Developer Edition (35.0a2) in Windows XP SP3 there seems to been an issue when playing multiple HTML5 audio files at once (see attached example page). 

Drop a couple of MP3 files into your root directory (or wherever you're testing the web page from), and change the filenames in the source code to point to them. 

Now open the page in Firefox and try to adjust the volume controls of the audio files individually. 





Actual results:

When playing multiple audio files, adjusting the volume control of any audio sample seems to adjust the volume of *all* audio files being played simultaneously - so it's impossible to adjust their volumes individually. 

This also seems to affect the master 'wave' controller of the sound card, i.e. if you turn either one of the audio volumes on the test page right the way down, and then go to view your master volume control from the system tray, the 'wave' controller's audio should be turned right the way down too. 


Expected results:

The volumes of all audio samples should work independently of one another, so all samples can be played at different levels. This is how it works in any of the previous versions of Firefox it's been tested on (27.0, 31.0, etc). There also seems to be another problem with audio files when using Windows 7, but I will post this as a separate issue.
Group: core-security
Component: Untriaged → Video/Audio
Product: Firefox → Core
Summary: HTML5 Audio issue in Windows XP SP3 → Volume control for HTML5 Audio in Windows XP SP3 controls global wav output volume
Whiteboard: DUPEME
Blocks: MSE
> Build ID: 20141108040201

Should be fixed by newer builds.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 1092859
You need to log in before you can comment on or make changes to this bug.