Closed Bug 1109432 Opened 7 years ago Closed 6 years ago

[FFOS2.0][SDM][Call]'Short vibration when call connected' is not support

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: wudduc, Unassigned)

References

Details

ALPS01860031
Question: Please help to check if this function need support?

DEFECT DESCRIPTION:
 Set SDM dialer.connected.vibrate as 0x01 'Short vibration when call connected' this is not support.
 
 REPRODUCING PROCEDURES:
 Set SDM dialer.connected.vibrate as 0x01.
 1.Make a call(MO/MT)
 2.'Short vibration when call connected' this is not support.
 
 EXPECTED BEHAVIOUR:
 When Set SDM dialer.connected.vibrate as 0x01, when call is connect there should be a vibrate.
 
 中文描述:在通话链接后,手机没有出现短暂的震动提示, SDM值不生效。
 >TEL:0752-2611945(61945)
we have called "vibrate([50])" after call connected.but it's not work.
handled_call.js:
var req = navigator.mozSettings.createLock().get('dialer.connected.vibrate');
  req.onsuccess = function() {
  if (req.result['dialer.connected.vibrate']) {
    navigator.vibrate([50]);
  }
};
I think it's hardware limitation because of speaker can't be use when call connected.
Blocks: Woodduck
Summary: [FFOS2.0][SDM][Call]'Short vibration when call connected' this is not support → [FFOS2.0][SDM][Call]'Short vibration when call connected' is not support
(In reply to Wayne Chen [:xwaynec] from comment #2)
> I think it's hardware limitation because of speaker can't be use when call
> connected.

I have a question:
the vibration is depend on speaker ??
Hi Wayne,
Can you provide answer for comment 3? Thanks!
Flags: needinfo?(waychen)
Hi all,

Yes, vibrator depends on speaker, but only in this model (hardware limitation).
Flags: needinfo?(waychen)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.