Closing First Time Use panel or Privacy Panel from Task Manager get it stuck on the screen and block access to the homescreen

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: clement.lefevre, Assigned: kgrandon)

Tracking

({regression})

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

4 years ago
Opening some panels from the settings and closing them from the Task Manager can get these panels stuck on front of the screen. User is unable to close them (it's not really opened anymore) and can't interact with it.
While having this state, it is not possible anymore to have access to the Homescreen until reboot.

It looks like it open a new pane without having it in the task manager.
So when you kill the settings pane which is probably the father, you still have the son process as zombie state.


Step to reproduce :

Privacy Panel > Quided Tour > Open Task manager > Close it by moving window to the top > Phone get stuck with it on front of the screen, no way to go back to homescreen without restarting the phone.

Or

Developper > Run First Time Use > Close it with Task manager > close it by moving window to the top > Phone get stuck to the First Time use you was on until restart.

Build ID               20141210160208
Build Type             user
Gaia Revision          e04ab7651b1e0c67516e1cef7aa4bc6072529885
Gaia Date              2014-12-10 15:24:39
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0cf461e62ce5
Gecko Version          37.0a1
Build Name             KVT49L dev-keys
Device ID              flame
Firmware(Release)      4.4.2
Firmware(Incremental)  39
Firmware Date          Thu Oct 16 18:19:14 CST 2014
Bootloader             L1TC00011880
I saw it on 2.2 [1] but I am not able to repro on 2.1 [2]: You can't go to task manager if you ran the FTU from the developer menu. I am not able to test privacy panel as this app is not in 2.1. 

I don't think asking for a regression window makes sense here as the new task switcher was landed in 2.2.

[1] Gaia-Rev        e04ab7651b1e0c67516e1cef7aa4bc6072529885
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/0cf461e62ce5
Build-ID        20141210160208
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

[2] Gaia-Rev        97873dca486abf4162a3345e71b375806937bdec
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9faa165ac85d
Build-ID        20141211001204
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141120.194707
FW-Date         Thu Nov 20 19:47:17 EST 2014
Bootloader      L1TC00011880
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
[Blocking Requested - why for this release]: Regression from 2.1 that can affect the first time experience for the privacy panel.
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
blocking-b2g: 2.2? → 2.2+
QA Contact: jmitchell
Central Regression Window:

Last Working:
Device: Flame Master
Build ID: 20141204080450
Gaia: 0462090a99093049add9268d14cbc7e44c1d1ccb
Gecko: 29d086b32a26
Version: 37.0a1 (Master)
Firmware Version: v188-1

First Broken:
Device: Flame Master
Build ID: 20141205035850
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: 9eda28f821a2
Version: 37.0a1 (Master)
Firmware Version: v188-1

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 0462090a99093049add9268d14cbc7e44c1d1ccb
Gecko: 9eda28f821a2
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 529c5fcd234ffd108b57629673ca97c2ef73376d
Gecko: 29d086b32a26

GAIA pushlog:
https://github.com/mozilla-b2g/gaia/compare/0462090a99093049add9268d14cbc7e44c1d1ccb...529c5fcd234ffd108b57629673ca97c2ef73376d

-----------------------------------------------------------------------
B2G-Inbound Regression Window:

Last Working:
Device: Flame Master
Build ID: 20141204090247
Gaia: 256ffaa7ae85bc95cae269482fae7314fdbf2cc6
Gecko: 07a5a56ccf69
Version: 37.0a1 (Master)
Firmware Version: v188-1

First Broken:
Device: Flame Master
Build ID: 20141204100746
Gaia: a157339f944c70813b443c4bd4125fbb42961a53
Gecko: 01ea4b953e2b
Version: 37.0a1 (Master)
Firmware Version: v188-1

Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 256ffaa7ae85bc95cae269482fae7314fdbf2cc6
Gecko: 01ea4b953e2b
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: a157339f944c70813b443c4bd4125fbb42961a53
Gecko: 07a5a56ccf69

GAIA pushlog: https://github.com/mozilla-b2g/gaia/compare/256ffaa7ae85bc95cae269482fae7314fdbf2cc6...a157339f944c70813b443c4bd4125fbb42961a53

----------------------------------------------------------------------------------

Issue seems to be caused by patch for  Bug 1106411 - can you take a look Kevin?
Blocks: 1106411
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(kgrandon)
QA Contact: jmitchell
(Assignee)

Comment 4

4 years ago
It appears that the system role causes this to have some weird side-effect when in the task manager.

We'll need some other solution for this seems like. For now, we'll revert bug 1106411.

https://github.com/mozilla-b2g/gaia/commit/9f0253410773533fd181295c67df12541bf0b0d6
Assignee: nobody → kgrandon
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(kgrandon)
Resolution: --- → FIXED
This issue still reproduces on Flame 2.2.

Result: Unable to access homescreen after closing Privacy Panel through Task Manager. The device is stuck on Privacy Panel.

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141215040201
Gaia: e2a3e606675c346b6e6f35351a458040be599b09
Gecko: f14dcd1c8c0b
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
(In reply to Yeojin Chung [:YeojinC] from comment #5)
> This issue still reproduces on Flame 2.2.
> 
> Result: Unable to access homescreen after closing Privacy Panel through Task
> Manager. The device is stuck on Privacy Panel.

I cant reproduce this on today's master. The bug is still resolved/fixed but Comment 5 indicates this fix couldn't be verified?
(Reporter)

Comment 7

4 years ago
T(In reply to Sam Foster [:sfoster] from comment #6)
> (In reply to Yeojin Chung [:YeojinC] from comment #5)
> > This issue still reproduces on Flame 2.2.
> > 
> > Result: Unable to access homescreen after closing Privacy Panel through Task
> > Manager. The device is stuck on Privacy Panel.
> 
> I cant reproduce this on today's master. The bug is still resolved/fixed but
> Comment 5 indicates this fix couldn't be verified?

The issue seems to be fixed for Privacy Panel since it got a dedicated app and is on the Homescreen.
It still to be an issue for the "First Time Use" experience and I still can reproduce it on latest master from right now.

At the same time, I am still unsure and maybe is it unrelated, but I begin to think that when this bug is happening, the phone forgets the Wi-Fi it is currently connected to.
I strongly suspect it, maybe can I check to be sure, but if some of you notice it too…
See Also: → 1113332
I think this bug is fixed, and the behavior with FTE is a separate issue. On Flame 2.1, the user is not able to bring the card view during FTE at all, which seems to be the correct behavior.

Please see the issue on bug 1113332.

(In reply to Clément Lefèvre from comment #7)
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
The First Time Use app does not show up in the task manager (it has role of 'system' so is excluded.) I think we're done here and can handle any FTU follow-up in bug 1113332
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
(In reply to Sam Foster [:sfoster] (PTO until Jan 5th) from comment #9)
> The First Time Use app does not show up in the task manager (it has role of
> 'system' so is excluded.) I think we're done here and can handle any FTU
> follow-up in bug 1113332

Closing the bug as verified.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.