Helper Apps: user selection for "Open using" should be remembered

VERIFIED DUPLICATE of bug 86640

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 86640
16 years ago
2 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Bill Law)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
spun off from bug 57423 --specifically see bug 57423 comment 15 and bug 57423
comment 16.

basically, when the user selects the "Open using..." *and* selects a particular
app via the "Choose" button, the following should occur:

a. the next time the helper app dialog appears for that type, "Open using..."
will be selected and the application remembered.

b. this change will be reflected in the Helper Applications preferences panel.
[ie, as if it had been added via the "Advanced" button in the current design.]
i'd think this would still allow users to change their settings if they change
their minds. :)

c. this change will persist during the current session *as well as* subsequent
sessions.

d. if the use had *deselected* the "Always ask before opening..." checkbox in
the helper app dialog, (a) will not appear, but (b) and (c) will still be true.


observation: this is not the behavior with current trunk builds...with the odd
exception of bug 97707 [mac-only] --basically it's like (c), except that it only
persists for the current session.
(Reporter)

Updated

16 years ago
Blocks: 78106
Depends on: 86640
(Reporter)

Updated

16 years ago
Keywords: mozilla0.9.8, ui
*** Bug 111740 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

16 years ago
This sounds plausible.  Please reconcile it with bug 86640, which is aiming at 
a similar result, I think.  I'm making this bug a dup of that one (I think one 
redesign is enough).  I'm going to add a pointer there over to this bug to make 
sure people see this proposal (which I think is better since it doesn't suffer 
from the problems I recently noted there).

Would adopting this permit us to remove the Advanced... button from the dialog?

*** This bug has been marked as a duplicate of 86640 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
in comment 2: Would adopting this permit us to remove the Advanced... button
from the dialog?

yes, if (b) were implemented, then the Advanced button could be removed.
(Reporter)

Comment 4

16 years ago
since bug 86640 was renominated for buffy and summarily minused, i'm reopening
this one in hopes of clarifying this feature for buffy.
Status: RESOLVED → REOPENED
Keywords: nsbeta1
Resolution: DUPLICATE → ---
(Reporter)

Updated

16 years ago
QA Contact: sairuh → petersen

Comment 5

15 years ago
re-duping, since 86640 is +/2

*** This bug has been marked as a duplicate of 86640 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

15 years ago
yep, this looks fixed using 2003.01.13.08 trunk bits.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.