Closed Bug 57423 Opened 20 years ago Closed 19 years ago

choosing one-off helper app should add that helper app to prefs

Categories

(Core Graveyard :: File Handling, enhancement, P2)

enhancement

Tracking

(Not tracked)

VERIFIED FIXED
Future

People

(Reporter: sballard, Assigned: paulkchen)

References

(Blocks 1 open bug)

Details

Steps to reproduce:
Click on a link with a mime type for which no helper app exists (eg
audio/mpegurl in a clean build)
Select an application to view the item (eg /usr/X11R6/bin/xmms)
Press ok (the application will correctly launch to view the item)
Edit > Preferences > Helper applications

Expected results:
A mapping should exist from audio/mpegurl to /usr/X11R6/bin/xmms

Actual results:
There is still no mapping for audio/mpegurl


Of course, this is an RFE - it's perfectly valid behavior to treat the user's
selection as a once-off, but having the option for the other behavior would be
useful. One way to achieve this would be an "always use this program to open
files of this type" checkbox (wording stolen from windows "open with" dialog).

(Note: Filing as UNCONFIRMED since I have only tested M18, not the latest nightlies)
OS: Linux → All
Hardware: PC → All
Confirming based on my optimized trunk build from last night.  Adding 4xp
keyword since I believe 4.x did this.  (There's a chance I could be wrong, but I
*really* expect this behavior.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp
Removing 4xp keyword - I just confirmed that 4.x on Linux did not do this.
However, 4.x did not let you choose an application to open with - if an
application was not defined in preferences, it just offered to save the file.
This is new UI that was never there before, and thus not 4xp (however, that
doesn't make it less of a valid bug).
Keywords: 4xp
QA Contact: sairuh → shrir
I'm taking the liberty of making this dependent on my RFE for
input helper applications for file upload forms (bug 46135), 
because it is going to happen real soon now, and I would hate 
to think what might happen if people were working on both at 
the same time.  Thank you for your patience; in return I will 
vote for this RFE when 46135 is finished.  I do think it is a 
good idea.
Depends on: input-helper-apps
No longer depends on: input-helper-apps
nav triage: accepting and upgrading to a P2. 
Assignee: matt → pchen
Priority: P3 → P2
Please ignore the comments from me above
(Additional Comments From James Salsman 2000-10-25 01:59)
those were intended to be posted to a completely different 
bug (mutiple file upload) and I have no idea how they 
ended up on this one for adding helper apps.
nav triage team:

Marking nsbeta1-. After digging through the helper apps pref code, I don't think
we have time to get this done for beta1 especially since we need to add code to
the download dialog thingy.
Keywords: nsbeta1nsbeta1-
Depends on: 58811
Marking nsbeta1+, mozilla0.9.1
Keywords: nsbeta1-nsbeta1+
Target Milestone: --- → mozilla0.9.1
Blocks: 78106
Target Milestone: mozilla0.9.1 → mozilla0.9.2
nav triage: nice to have but not critical for rtm. moving to mozilla0.9.3. 
Target Milestone: mozilla0.9.2 → mozilla0.9.3
nav triage team:

Would really like this, but too much risk to take for mozilla0.9.3. Pushing out 
to mozilla1.0
Target Milestone: mozilla0.9.3 → mozilla1.0
Scott and Boris,

Is this really too much work for 0.9.3?

The dependency on bug 58811 is not strict at all,
because this could certainly be done without JavaScript.
So I am removing it if I can.

Also, "enhancement" is used in the "only to Mozilla; 
navigator had this really early" sense, right?
No longer depends on: 58811
Depends on: 59619
Chances are, in the process of fixing bug 86640 this one will get fixed.
Depends on: 86640
Summary: choosing one-off helper app should add that helper app to prefs → [RFE]choosing one-off helper app should add that helper app to prefs
I think this bug is a won't fix, as it can be set via the [set default...] button.
Component: Preferences → File Handling
QA Contact: shrir → sairuh
Target Milestone: mozilla1.0 → Future
Why is this bug still open? It isn't even a valid RFE anymore now that the
dialog has a "set default" button. As the original reporter, I think this bug
should be either marked fixed, marked wontfix or dupped against whichever bug
added the "set default" button.

The behavior specified here would be *more* confusing than the existing set
default button, now that we have one.
marking fixed per stuart's comments.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
if we're talking about the helper app dialog that appears, there is no Set
Default button [at least since 0.9.4].

during a recent bug triage meeting with Peter and Bill, we had discussed this
issue --that most users expect that selecting the application for a given type
from this dialog should

a. [iirc] remember that that application selection should stick for subsequent
attempts to click such types [during the same and subsequent sessions, too].
b. that decision should also be reflected in the Helper Applications prefs panel.

i willing to verify this one --if there are other bugs already filed for these
issues.

bill, do you know if said bug[s] exist? [drat, i cannot reassign resolved
bugs... this best belongs to you, i think.]
Summary: [RFE]choosing one-off helper app should add that helper app to prefs → choosing one-off helper app should add that helper app to prefs
Treating the user's choice as a one-off is only useful for wierd <1% cases, the
typical case is that the mapping they specify is the one they always want, and
if that is not the case, they can easily indicate they want to be asked each
time.  The vast majority of users don't even want to have to specify this
mapping once, they just expect it to work.  I know I find it maddening when I
have to continually tell the program that, yes, dammit, I want to open Acrobat
files using Acrobat. Considering the trouble I've gone to to install both
programs, why does it even ask? I'm extremely unlikely to suddenly decide to
open them using anything else, and if I wanted to save the file, I would have
issued the Save As command rather than clicked. 
rs vrfy...

filed bug 111035 re: comment #15 and comment #16.
No longer blocks: 78106
Status: RESOLVED → VERIFIED
Whoever takes bug 46135 needs to know about this.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.