Closed Bug 1110462 Opened 8 years ago Closed 8 years ago

fix behavior for invalid schemes in Service Worker Cache

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 940273

People

(Reporter: bkelly, Unassigned)

References

Details

Currently the Service Worker Cache code will reject if any method tries to use a URL with a schema other than http or https.  This is incorrect.  Only add(), addAll(), and put() should reject.  Methods like match() and matchAll() should instead act as though they matched nothing.
Doing this one as part of review feedback in bug 940273.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940273
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.