Trunk crash [@ FrameManager::ReResolveStyleContext]

VERIFIED DUPLICATE of bug 105619

Status

()

Core
Layout
--
critical
VERIFIED DUPLICATE of bug 105619
17 years ago
15 years ago

People

(Reporter: jay, Assigned: Marc Attinasi)

Tracking

({crash, topcrash})

Trunk
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

17 years ago
This is a topcrasher with recent MozillaTrunk builds.  It looks like most of the
recent crashes were reported by the same person, but the crash URL is
consistent: http://www.iht.com/.  This is happening on all flavors of Windows,
here is the latest info from Talkback:

FrameManager::ReResolveStyleContext   18 
BBID range: 37938063 - 38247461
Min/Max Seconds since last crash: 8 - 97465
Min/Max Runtime: 12 - 97465
Crash data range: 2001-11-12 to 2001-11-19
Build ID range: 2001111209 to 2001111910
Keyword List : 
Stack Trace: 

	 FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp  line 1668]
	 FrameManager::ReResolveStyleContext
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp  line 1806]
	 FrameManager::ComputeStyleChangeFor
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp  line 2066]
	 nsCSSFrameConstructor::AttributeChanged
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 10173]
	 StyleSetImpl::AttributeChanged
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp  line 1470]
	 PresShell::AttributeChanged
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5125]
	 nsDocument::AttributeChanged
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp  line 1796]
	 nsHTMLDocument::AttributeChanged
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLDocument.cpp  line
1272]
	 nsDOMCSSAttributeDeclaration::ParsePropertyValue
[d:\builds\seamonkey\mozilla\content\html\style\src\nsDOMCSSAttrDeclaration.cpp
 line 284]
	 CallSetProperty
[d:\builds\seamonkey\mozilla\content\html\style\src\nsDOMCSSDeclaration.cpp 
line 229]
	 nsDOMCSSDeclaration::SetHeight
[d:\builds\seamonkey\mozilla\content\html\style\src\nsDOMCSSDeclaration.cpp 
line 300]
	 XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp 
line 154]
	 XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp  line 2011]
	 XPC_WN_GetterSetter
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp 
line 1291]
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 834]
	 js_InternalInvoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 925]
	 js_SetProperty
[d:\builds\seamonkey\mozilla\js\src\jsobj.c  line 2601]
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2648]
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 850]
	 js_Interpret
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 2792]
	 js_Invoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 850]
	 js_InternalInvoke
[d:\builds\seamonkey\mozilla\js\src\jsinterp.c  line 925]
	 JS_CallFunctionValue
[d:\builds\seamonkey\mozilla\js\src\jsapi.c  line 3407]
	 nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp  line 991]
	 nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp  line 182]
	 nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp  line
1214]
	 nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp  line
1384]
	 nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp  line 1880]
	 nsHTMLImageElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLImageElement.cpp 
line 582]
	 PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5846]
	 PresShell::HandleEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5816]
	 nsEventStateManager::CheckForAndDispatchClick
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp  line 2456]
	 nsEventStateManager::PostHandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp  line 1539]
	 PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5867]
	 PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 5771]
	 nsView::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 375]
	 nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp  line 1874]
	 HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp  line 84]
	 nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 838]
	 nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 855]
	 nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4409]
	 ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 4659]
	 nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 3375]
	 nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp  line 1103]
	 USER32.DLL + 0x2e98 (0x77e12e98)
	 USER32.DLL + 0x30e0 (0x77e130e0)
	 USER32.DLL + 0x5824 (0x77e15824)
	 nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 303]
	 main1
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1316]
	 main
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1633]
	 WinMain
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1651]
	 WinMainCRTStartup()
	 KERNEL32.DLL + 0x17d08 (0x77e97d08)
 
 	Source File :
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/base/src/nsFrameManager.cpp
line : 1668
     (38247461)	URL: http://www.geocities.com/wranlon/portal.html
(38247461)
Comments: Crashed when interacting with DHTML on above site.
     (38247347)	URL: http://www.geocities.com/wranlon/portal.html
(38247347)
Comments: Crashed when DHTML window was minimized.
     (38186519)	URL: http://www.iht.com/
(38186519)
Comments: crashed!!!
     (38173468)	URL: www.iht.com
(38146695)
URL: http://www.iht.com/
(38146695)
Comments: just crashing
     (38102755)	URL: http://www.iht.com/
(38100574)
URL: http://www.iht.com/
(38100574)
Comments: just crashed
     (38100011)	URL: http://www.iht.com
(38100011)
Comments: crash on load
     (38097160)	URL: http://www.iht.com
(38097160)
Comments: crash
     (38088125)	URL: http://www.iht.com
(38088125)
Comments: crash on loading
     (38039436)	URL: http://www.iht.com/
(38013962)
URL: www.iht.com
(37989288)
URL: http://www.iht.com
(37989288)
Comments: just went to site
     (37959978)	URL: www.iht.com
(37941405)
URL: www.iht.com
(Reporter)

Updated

17 years ago
Keywords: crash, topcrash

Comment 1

17 years ago
*** Bug 111268 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
This crashes on MacOS 9.x as well.

Platform/OS -> All?
*** Bug 111585 has been marked as a duplicate of this bug. ***

Updated

17 years ago
OS: Windows 2000 → All
Hardware: PC → All

Comment 4

17 years ago
0.9.6 on Linux also.

Comment 5

17 years ago
*** Bug 112085 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
*** Bug 112087 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
I'm crashing at http://www.iht.com (the frontpage) : talkback id's TB38555303X
and TB38555268H

Build ID 2001112009 (regular 0.9.6) on Windows NT 4.0 SP 6a
*** Bug 112122 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Noted yesterday that this is actually a dup of bug 105619. The root cause is
that style data become corrupted on that page, and the crash occurs because
style data pointers in ReResolveStyleContext simply mean nothing.

Comment 10

17 years ago
based on rbs comment, marking as dup of 105619, David please reassign if this is 
not the case

*** This bug has been marked as a duplicate of 105619 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 11

15 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Crash Signature: [@ FrameManager::ReResolveStyleContext]
You need to log in before you can comment on or make changes to this bug.