Closed Bug 1111139 Opened 5 years ago Closed 5 years ago

Update tutorial update configs for 2.2

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master fixed)

VERIFIED FIXED
2.2 S4 (23jan)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- fixed

People

(Reporter: sfoster, Assigned: sfoster)

References

Details

(Whiteboard: systemsfe)

Attachments

(1 file)

The tutorial screens to show for each supported update scenario live in JSON config files. These currently reference 2.1 and updates from 1.3 and 1.4. We only support updates from 2 minor version back, so we just need 2.0->2.2 and 2.1->2.2
blocking-b2g: --- → 2.2+
Assignee: nobody → sfoster
No longer blocks: 1104194
Depends on: 1104194
Blocks: 1122703
Updates FTU tutorial steps to include app-grouping. 
Remove unused strings. New string for app-grouping step.
App Grouping video is placeholder, will be updated in bug 1122703
Attachment #8550474 - Flags: review?(fernando.campo)
Attachment #8550474 - Flags: review?(fernando.campo) → review+
Gaia-Try had just 1/10 intermittent
Merged to master: https://github.com/mozilla-b2g/gaia/commit/4456dfa018ab6f01ef32b9736cf1254f0a11f7a7
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please nominate this for v2.2 approval when you get a chance.
Flags: needinfo?(sfoster)
Target Milestone: 2.2 S2 (19dec) → 2.2 S4 (23jan)
Comment on attachment 8550474 [details] [review]
PR: Update tutorial configs, new/placeholder video assets

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): FTU Tutorial / App Grouping Homescreen feature
[User impact] if declined: Missing tutorial for App Grouping
[Testing completed]: Gaia-Try, tested on Flame
[Risk to taking this patch] (and alternatives if risky): Low 
[String changes made]:  New string for app grouping step in tutorial

This patch includes a placeholder video, which is replaced in bug 1122703
Flags: needinfo?(sfoster)
Attachment #8550474 - Flags: approval-gaia-v2.2?
Attachment #8550474 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
verified by 2.0->2.2

*build id:
-2.0: 20150414160202
-2.2: 20150414162502
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.