Filter action delete from POP server doesn't work

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: miaposta21_, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

1. Create a filter with the action "delete from POP server"
2. Send yourself a mail with the corresponding criteria



Actual results:

The mail will be downloaded instead of deleted from server


Expected results:

The mail should have been deleted from server and not downloaded

Comment 1

4 years ago
It will of course first have to download to match the filter. So is the message available *on the server* after the filter ran?
(Reporter)

Comment 2

4 years ago
If the filter is on the subject does it have to download the body? If the message has attachments does it have to download them? To be clear the goal of the filter should be this: not having the message in your mail client if the filter is matched. In the actual state having this filter or not having this filter doesn't make any difference.

Comment 3

4 years ago
Yes it has to be downloaded to see if there are attachments. Subjects might be downloadable separately, but unless you set up mails to always download just headers I doubt that will work the way you want in filters. The purpose of that filter action is more to let you e.g. remove matching mails from the server to save space.
(Reporter)

Comment 4

4 years ago
So if you already delete mail from server upon download this filter is useless, right?

Comment 5

4 years ago
yes

Comment 6

2 years ago
Not sure if it is related, I am trying not to duplicate a bug.

I had emails from 2014 on the server, and although I selected "keep messages on server for at most" 720 days, these emails would not get deleted. I erased my profile and retried, again messages do not get deleted. Finally I just removed the check on "keep messages on server" and closed Thunderbird with then downloaded messages got to 2016... this too did not work.

I had to empty the entire server for Thunderbird to delete the 2014 messages.
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.