bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[RFE] Add print preview menu command to the nav bar.

VERIFIED FIXED

Status

()

Core
Printing: Output
--
enhancement
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: brian, Assigned: rods (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Add the print preview menu command to the drop down print button list in the
navigation bar.
over to rods, who's doing print preview
Assignee: dcone → rods
Status: UNCONFIRMED → NEW
Ever confirmed: true
Taking this bug
Assignee: rods → cbiesinger
Status: NEW → ASSIGNED
Created attachment 58722 [details] [diff] [review]
Suggested Patch

This should fix the bug. bz, could you review?
I was told that the print dropdown menu will be removed soon, but not in
commercial builds, and that I should not waste my time with this bug.

So, reassigning to default owner to decide whether to get sr and check this in
or only checking it into commercial tree.
Assignee: cbiesinger → rods
Status: ASSIGNED → NEW

Comment 6

17 years ago
Since bug 63042 (remove the menu) is futured, I don't see why this fix should 
be commercial-only.
*** Bug 113604 has been marked as a duplicate of this bug. ***
Jesse's right.  We have many things that are "soon to be removed" (eg non-XBL
form controls).  It's not happening any time soon, and neither is bug 63042.

biesi, you should just ask blake for sr

Updated

17 years ago
Keywords: mozilla0.9.8

Comment 9

17 years ago
Comment on attachment 58722 [details] [diff] [review]
Suggested Patch

sr=blake
Attachment #58722 - Flags: superreview+
Checked in.  Thanks for doing this, biesi!
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 11

17 years ago
this is still not fixed in 12/13 build...I only see "Print" when clicking
on the Print icon to see the drop down menu.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
sujay, is this a mozilla or commercial build?  Also, this is trunk, right?

Comment 13

17 years ago
yes, commercial trunk...12/13 build on win.

I definitely don't see the Print Preview in the pull-down print icon.
This worksforme on mozilla builds.  Sounds like a commercial-only problem. 
Perhaps commercial has a separate XUL file here?
sujay: What about filing a Bugscape bug for this, in Mozilla this is obviously
working.

Comment 16

17 years ago
ok I see it now in 12/18 commercial trunk build.

Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 17

17 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 18

16 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement
You need to log in before you can comment on or make changes to this bug.