[e10s] Ongoing download gets canceled in private browsing mode if tab starting the download gets closed

VERIFIED FIXED in Firefox 41

Status

()

Firefox
Private Browsing
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: aryx, Assigned: mrbkap)

Tracking

Trunk
Firefox 41
x86_64
Windows 8.1
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(e10sm7+, firefox41 fixed)

Details

(Whiteboard: [testday-20150821])

Attachments

(1 attachment)

Firefox Nightly 37.0a1 20141214030205 on Windows 8.1

Ongoing downloads gets canceled in private browsing if the tab starting the download gets closed.

My STR:
1. Set Firefox to always start in Private Browsing mode.
2. Go to https://air.mozilla.org/intern-presentations-36/
3. Below the video, click "Download".
4. Right-click "WebM" and "Save as".
5. Pick location and save the file.
6. While the download is still ongoing, open a new tab and close the one with https://air.mozilla.org/intern-presentations-36/

Actual result:
Download gets canceled when closing the tab which started it.

Expected result:
Download continues and is not bound to a tab.

Comment 1

4 years ago
> Download gets canceled when closing the tab which started it.
That's not completely true.

I opened this bug-page in the browser, middleclicked on the URL, AirMozilla is opened in a new tab, and I started the download from there.

Closing the AirMozilla-tab didn't stop the download, but opening a new tab and closing the Bugzilla-tab, from which the AirMozilla-tab was opened, did stop the download.
tracking-e10s: --- → m7+
Flags: firefox-backlog+
Assignee: nobody → mrbkap
(Assignee)

Comment 2

3 years ago
Created attachment 8620737 [details] [diff] [review]
Potential patch

Ehsan, are you the right reviewer here?

This seems to be a case where we're firing a notification when we shouldn't be. The key is that when privtebrowsing.autostart is true, we probably shouldn't fire last-pb-context-exited.
(Assignee)

Updated

3 years ago
Attachment #8620737 - Flags: review?(ehsan)

Updated

3 years ago
Attachment #8620737 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/3fdc89601dd5
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
QA Whiteboard: [good first verify][verify in Nightly only]

Comment 5

3 years ago
I have reproduced this bug with Firefox Nightly 37.0a1 (Build ID:20141215030201) on 
windows 8.1 pro 64-bit with the instructions from comment 0 .

Verified as fixed with Latest Firefox Nightly 43.0a1 (Build ID:20150822030206)

Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Whiteboard: [testday-20150821]

Comment 6

3 years ago
This bug's fix is verified in latest Firefox beta ( 42.0) [testday-20151002]

Comment 7

3 years ago
(In reply to preethi.dhinesh from comment #6)
> This bug's fix is verified in latest Firefox beta ( 42.0) [testday-20151002]
It is verified as Fixed with latest firefox beta 42.0

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.