Improve visibility into reason of failures

RESOLVED DUPLICATE of bug 1122505

Status

Hello (Loop)
General
P3
normal
RESOLVED DUPLICATE of bug 1122505
3 years ago
3 years ago

People

(Reporter: RT, Unassigned)

Tracking

unspecified
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [investigation])

User Story

Currently we have abnormally high "busy" and "timeout" termination reasons (https://metrics.services.mozilla.com/loop-server-dashboard/) and we need more clarity on the following:
- Are these not applicable in rooms anymore?
- The "busy" termination reason is not detailed enough (The user is logged in, but cannot answer the call due to some current state (e.g., DND, in another call). We need more details about why calls are  marked as busy in order to understand if we have issues in the handshake flow.
- The "timeout" termination reason is not detailed enough (The call setup has timed out (The called party's client has exceeded the amount of time it is willing to alert the user, or one of the server's timers expired). We need more details about why calls are  marked as timeout in order to understand if we have issues in the handshake flow. More particularly we want to understand if the callee has hit the "answer" button when timeout scenarios occur.
Comment hidden (empty)
(Reporter)

Updated

3 years ago
Blocks: 1110512
User Story: (updated)
I'd like to improve these ASAP.
backlog: --- → Fx37?
Priority: -- → P2

Updated

3 years ago
backlog: Fx37? → Fx38?

Updated

3 years ago
backlog: Fx38? → Fx38+

Comment 2

3 years ago
need a discussion with ABR on what we want to collect for rooms.  the list below right now is direct call only.  investigation will reveal if client, server, other work.
Component: Client → General
Whiteboard: [investigation]

Comment 3

3 years ago
will update to making for server errors - and change from calls focus
Flags: needinfo?(rtestard)
Priority: P2 → P3
(Reporter)

Comment 4

3 years ago
Bug 1122505 and bug 1122494 address the room requirements
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(rtestard)
Resolution: --- → DUPLICATE
Duplicate of bug: 1122505
You need to log in before you can comment on or make changes to this bug.