"Change Search Settings" button in search toolbox is cut off

RESOLVED FIXED in Firefox 38

Status

()

Firefox
Search
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Petruta Rasa [Away. Please needinfo? bogdan.maris@softvision.ro], Assigned: florian)

Tracking

35 Branch
Firefox 38
Points:
---

Firefox Tracking Flags

(firefox38 fixed)

Details

Attachments

(1 attachment)

Reproduced with Firefox 35 beta 3, latest Dev Edition 36.0a2 and latest Nightly 37.0a1 2014-12-15 under Win 7 64-bit, Ubuntu 14.04 32-bit and Mac OSX 10.9.5.

STR: Set the browser to a small width and open the search toolbox panel by clicking on the magnifying glass or writing something.

AR: The "Change Search Settings" text is cropped.

ER: The button fits the panel just like the search engine's name and the "Search for <item> with"

Screenshot: http://i.imgur.com/FyvlkxN.png

Note: On Windows, the issue reproduces at a bigger width having the setup from bug 1108841: search for "color" in the Control Panel, then click on "Change window colors and metrics", and there change the "Message Box" font size (12px or higher).
(Assignee)

Comment 1

4 years ago
The steps to reproduce using a small browser window will no longer work once we fix bug 1106054.
While bug 1106054 has addressed this issue for Windows and Mac, it still hasn't addressed the issue on Linux (for 35 Beta, 36 Aurora and 37 Nightly).

Steps to reproduce:
1. Open Firefox and reduce the window width to the minimum that will still show the Search bar.
2. Start typing in the Search bar and see how the dropdown displays.

Results: The Search dropdown fits 3 search engines per row, fits a relatively ok part of the suggestions, but the "Search for <term> with:" and "Change Search Settings" labels still do not fit well. See http://www.screencast.com/t/l1thdb8IAbV for the remaining Ubuntu issue.

The remaining Linux issue is tracked here as suggested in https://bugzilla.mozilla.org/show_bug.cgi?id=1106054#c17.
Currently this looks pretty terrible on localized builds. I never noticed it because OS X looks good, but it's definitely broken on Linux (just got a message on our support forum), need to check on Windows.

http://transvision.mozfr.org/string/?entity=browser/chrome/browser/browser.dtd:changeSearchSettings.button&repo=release

I think we're basically cutting off the UI for the large majority of locales. These strings should really wrap.
(Assignee)

Comment 4

3 years ago
Created attachment 8562817 [details] [diff] [review]
Add an l10n-note

I see no straightforward way to make the button label wrap, so I think the best we can do in the short-term is to add a localization note suggesting that translating the word "Change" is not required.
Attachment #8562817 - Flags: review?(francesco.lodolo)
Comment on attachment 8562817 [details] [diff] [review]
Add an l10n-note

Review of attachment 8562817 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. 

On second thoughts, given how far we're in the cycle I think it's enough to land this on mozilla-central without bothering with mozilla-aurora. 
I'll also send a message out to dev-l10n
Attachment #8562817 - Flags: review?(francesco.lodolo) → review+
https://hg.mozilla.org/mozilla-central/rev/c7cd5f23fa8d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
I'm still seeing this issue on Ubuntu 14.04 (x64), with en-us Nightly 40.0a1 (2015-04-22) - screenshot: http://i.imgur.com/EYk5sF6.png. Florian, I thought the patch mentioned in Comment 4 was handling this as well, was I wrong?
Flags: needinfo?(florian)
(Assignee)

Comment 9

3 years ago
(In reply to Andrei Vaida, QA [:avaida] from comment #8)
> I'm still seeing this issue on Ubuntu 14.04 (x64), with en-us Nightly 40.0a1
> (2015-04-22) - screenshot: http://i.imgur.com/EYk5sF6.png. Florian, I
> thought the patch mentioned in Comment 4 was handling this as well, was I
> wrong?

The patch wasn't fixing anything for en-US. We don't have any straight forward way to fix this, unfortunately. The only thing the patch did is add a localization note so that localizers know that this is an issue, and don't make the issue worse in localized builds by using longer strings.
Flags: needinfo?(florian)
You need to log in before you can comment on or make changes to this bug.