[WIFi] User can not connect to wifi through the notification screen

VERIFIED FIXED

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: psiphantong, Assigned: arthurcc)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-exploratory-2], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Posted file wf.txt
Description:
When logging in to wifi through the notification screen, the user will not be connected.


Repro Steps:
1) Update a Flame to 20141215040201
2) Pull down the notification screen
3) Double tap the wifi icon
4) Login with password 


Actual:
can not connect to wifi 

Expected:
connect to wifi 


Flame 2.2

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141215040201
Gaia: e2a3e606675c346b6e6f35351a458040be599b09
Gecko: f14dcd1c8c0b
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 37.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Notes: User is able to connect through settings


Repro frequency:100%,
See attached:logcat,video clip:https://www.youtube.com/watch?v=xmBSXF6L6AY
(Reporter)

Comment 1

4 years ago
This issue does not reproduce on the Flame 2.1 and the Flame 2.0, user is able connect to wifi.

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141215001202
Gaia: 97873dca486abf4162a3345e71b375806937bdec
Gecko: ec87f4f41d3d
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Device: Flame 2.0 (319mb) (KitKat Base)(Full Flash)
Build ID: 20141212000203
Gaia: f3b9806f687fbbd7eba6b0e1f6ebb8bde09840ea
Gecko: 32f9fae79b89
Gonk: 263b5f41f7733c5577fb101eb4dc8ac5c11cfa8d
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

User should be able to connect to wifi through the notification tray without issue. Also a regression Nominating to block 2.2
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Contact: jmercado
Bug 1090843 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141212014254
Gaia: 739dd45496e9d0f1806dc67faf0244c18c5dd3ac
Gecko: 6fe07f7f9c81
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141212021253
Gaia: 19f12e8d9308f8d7fde3b97c7f8b7b58bd876222
Gecko: 164e01fe269f
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working gaia / First Broken gecko - 
Gaia: 739dd45496e9d0f1806dc67faf0244c18c5dd3ac
Gecko: 164e01fe269f

First Broken gaia / Last Working gecko - 
Gaia: 19f12e8d9308f8d7fde3b97c7f8b7b58bd876222
Gecko: 6fe07f7f9c81

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/739dd45496e9d0f1806dc67faf0244c18c5dd3ac...19f12e8d9308f8d7fde3b97c7f8b7b58bd876222
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
caused by the patch to Bug 1090843 - can you take a look Arthur?
Blocks: 1090843
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(arthur.chen)
QA Contact: jmercado
I'll check the issue.
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
Status: NEW → ASSIGNED
EJ, per our offline discussion, could you help review this simple patch? Thanks.
Attachment #8538428 - Flags: review?(ejchen)
Comment on attachment 8538428 [details]
link to https://github.com/mozilla-b2g/gaia/pull/26878

Thanks Arthur, r+ !

BTW, I just noticed that we may have to change that '<' button to 'x' when we finished refactoring dialogService. With refactored dialogService, related panels have been refactored with dialog format and we can use 'data-icon' to change the icon at runtime based on current situation (webActivity for example).
Attachment #8538428 - Flags: review?(ejchen) → review+
Thanks, EJ!

master: 01e9a802eed12d2331af62bc7a172be1376f21b8
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 9

4 years ago
Verified, the issue is fixed on Flame 2.2

Device is connected to WiFi through settings

"Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141219040202
Gaia: deb90229734e5397cda806fb11f2e001fba83399
Gecko: 021b09e92d30
Gonk: e5c6b275d77ca95fb0f2051c3d2242e6e0d0e442
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0"
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
blocking-b2g: 2.2? → 2.2+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.