Closed Bug 1111906 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Woodduck][Music player][FM]after deal with alarm,would short play music and then play FM

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED DUPLICATE of bug 1069887
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: sync-1, Unassigned)

References

Details

Attachments

(4 files)

DEFECT DESCRIPTION:
 after deal with alarm,would short play music and then play FM
 
  REPRODUCING PROCEDURES:
 1.Launch FM and select one channel to play;
 2.Launch music player and select one song to play;
 3.Press home key to let music play background;
 4.Coming an alarm during music playing,deal with this alarm.
 It would short play music,and then play FM.->KO
 
  EXPECTED BEHAVIOUR:
 Should always play music.ranther than short play.
Attached file log
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Blocks: Woodduck
blocking-b2g: --- → 2.0M?
Flags: needinfo?(fan.luo)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Attached file Flame2.0 logcat
The bug can be repro on Woodduck 2.0/Flame 2.0, and it verified not happen on Flame 2.1/2.2.
See attachments: Woodduck2.0_logcat_1516.log & Flame2.0_logcat_1530.txt & Video.MP4
Repro time: Woodduck2.0: 15:16, Flame2.0: 15:30
Reproducing rate: 0/5

Woodduck 2.0 build:
Gaia-Rev        09097552f236b1482ce469b4c7d92d80d0706f83
Gecko-Rev       aa9ece9c8a749095834e7a980166543d985a3af5
Build-ID        20141217050313
Version         32.0

Flame 2.0 build:
Gaia-Rev        f3b9806f687fbbd7eba6b0e1f6ebb8bde09840ea
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/12aea1649f5a
Build-ID        20141216000202
Version         32.0

Flame 2.1 build:
Gaia-Rev        79286eafe67707d1330966c1b1413b2d0de595d9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/222a62b532db
Build-ID        20141216001202
Version         34.0

Flame 2.2 build:
Gaia-Rev        af3d2f89f391c92667e04676fc0ac971e6021bb7
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a3030140d5df
Build-ID        20141216040205
Version         37.0a1
Flags: needinfo?(fan.luo)
Attached video Video
Hi Wayne,
Could you please help to check the audio problem? Thanks!
Flags: needinfo?(waychen)
There is no obvious difference in audiochannel between 2.0 with 2.1. Need more investigation.
FM app received the "private.broadcast.attention_screen_opening"
and try to enable again @fm.js:873.
(In reply to comment #10)
 > Comment from Mozilla:FM app received the
 > "private.broadcast.attention_screen_opening"
 > and try to enable again @fm.js:873.
 > 
 
 can we remove this function ??
 navigator.mozSettings.addObserver(
     'private.broadcast.attention_screen_opening',
 ...
 }
 looks like FM don't need this.
Hi Josh,

Could you find Fm app owner to check that. Thanks
Flags: needinfo?(waychen) → needinfo?(jocheng)
Hi Tim,
Can you help to check this FM bug? Thank you!
Flags: needinfo?(jocheng) → needinfo?(timdream)
Blocks: Woodduck_P2
Redirect to media team.
Flags: needinfo?(timdream) → needinfo?(dflanagan)
Hi Pin,
Can you also take a look?
Thanks!
Flags: needinfo?(pzhang)
Hi Josh, I think it's the same problem with bug 1069887, please feel free to re-open this if I'm wrong.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(pzhang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1069887
Hi Pin,
Thanks. I see there haven't been any activity after 11/6. Can you give me a quick status of this bug? Thanks!
Flags: needinfo?(dflanagan) → needinfo?(pzhang)
Hi Josh, :justindarc was working on bug 1069887, he didn't update the patch since my last review, i don't know if he is still working on this, let's ni? him.
Flags: needinfo?(pzhang)
any updates?
blocking-b2g: 2.0M? → ---
hi
 
 it seems like bug1069887 also duplicate of bug1113086. and bug1113086 won't fixed on 2.0 version.. so this bug also  wontfix on woodduck ?
You need to log in before you can comment on or make changes to this bug.