Closed Bug 1111998 Opened 5 years ago Closed 5 years ago

[Flame][Notifications]The Play icon overlap the search box on notification bar.

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 wontfix, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S3 (9jan)
blocking-b2g 2.2+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.0M --- unaffected
b2g-v2.1 --- wontfix
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: zikui.yang, Assigned: gmarty)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(5 files)

[1.Description]:
[Flamev2.1][Notification]When play music with headset,try to share a music by Message,return to Music view,the Play icon overlap the search box on notification bar.
Attachment:VIDEO0164_Compress.MP4 and logcat.txt
Happen time:1:04

[2.Testing Steps]: 
1.Insert headset
2.Launch music and play a song
3.Tap Share icon ->tap messages
**It will promot that the file is too large to share 
4.Tap Ok to return Music view  

[3.Expected Result]: 
5.The Play icon should overlap the search box on notification bar,and the headset icon should be hided.

[4.Actual Result]: 
4.The Play icon overlap the search box on notification bar.

[5.Reproduction build]: 
Gaia-Rev        97873dca486abf4162a3345e71b375806937bdec
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ec87f4f41d3d
Build-ID        20141215001202
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
Attached video VIDEO0164_Compress.MP4
Attached file logcat.txt
Thats filed for 2.1. Can we do a branch check and see if this reproduces on master as well?
Keywords: qawanted
Whiteboard: [systemsfe]
QA Contact: ckreinbring
The bug repros on Flame 2.2 and 2.1 engineering with shallow flash.
Actual result: After returning to the Music app from the "file too large" message, the icons on the status bar will overlap the rocketbar search box if there are enough icons to overlap it.

Flame 2.2
BuildID: 20141216130413
Gaia: 8ffb48c321bb9595ad437086c5eb450bc90aa714
Gecko: 8401afdb6e6c
Platform Version: 37.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Flame 2.1
BuildID: 20141216123009
Gaia: b868736aec314c5e69c1329249f170c7b07802ea
Gecko: 7b161e9fe25e
Platform Version: 34.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Flame 2.0 engineering with shallow flash.
Actual result:  There is no rocketbar box to be overlapped by the status bar icons.

Flame 2.0
BuildID: 20141216125712
Gaia: d04710d5d643eeff5a6493aef92a1af672a2769c
Gecko: 0ba3d86b4e78
Platform Version: 32.0
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
Nomming for 2.2  - (not 2.1, due to timing), Regression, poor UX
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Regression window
Last working
BuildID: 20141013185057
Gaia: 4f86c631e0465c0e56ccebeb1324fd28be9ea32f
Gecko: 54217864bae9
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141014062953
Gaia: de254419f3553f48187d003ee8e38034b429f069
Gecko: 56330f74fbef
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 4f86c631e0465c0e56ccebeb1324fd28be9ea32f
Gecko: 56330f74fbef
Broken Gaia / Working Gecko = Repro
Gaia: de254419f3553f48187d003ee8e38034b429f069
Gecko: 54217864bae9
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/4f86c631e0465c0e56ccebeb1324fd28be9ea32f...de254419f3553f48187d003ee8e38034b429f069


B2G Inbound
Last working
BuildID: 20141013204756
Gaia: ec355e1c02ebffbfda778661c2501a0bc78317dc
Gecko: b6e9b4bc9630
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141013213259
Gaia: 711daa290264a1ad9a7708fccca05f41d5482a49
Gecko: 8f2d3858d2b3
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: ec355e1c02ebffbfda778661c2501a0bc78317dc
Gecko: 8f2d3858d2b3
Broken Gaia / Working Gecko = Repro
Gaia: 711daa290264a1ad9a7708fccca05f41d5482a49
Gecko: b6e9b4bc9630
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/ec355e1c02ebffbfda778661c2501a0bc78317dc...711daa290264a1ad9a7708fccca05f41d5482a49
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Regression caused by patch to  	Bug 1074028 - can you take a look Kevin.
Blocks: 1074028
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kgrandon)
QA Contact: ckreinbring
blocking-b2g: 2.2? → 2.2+
I probably won't be able to get to this before the holidays, but since it's a blocker someone on our team will in 2.2. Clearing ni flag.
Flags: needinfo?(kgrandon)
I could not reproduce this in [1].

[1]: The environment:
Build ID               20141229160214
Gaia Revision          322ef5116a5827a30c9a3cd9b842449a9c66a5b3
Gaia Date              2014-12-29 18:03:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2c0ef7315830
Gecko Version          37.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20141229.192338
Firmware Date          Mon Dec 29 19:23:49 EST 2014
Bootloader             L1TC00011880
Hi Elie,

I could not reproduce this bug.
Could we close it?

Thanks.
Flags: needinfo?(zikui.yang)
(In reply to Evan Tseng [:evanxd][:愛聞插低] from comment #10)
> Hi Elie,
> 
> I could not reproduce this bug.
> Could we close it?
> 
> Thanks.

Hi Evan,This issue still exist in flame 2.2:
Gaia-Rev        bdedbaf9f18a43c091ede770407d68d38582fe29
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/8850aa0f5332
Build-ID        20141229010215
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
Reproduce rate  5/5

Please keep BT and wifi ON ,NOT insert SIM card.Then,try to reproduce this issue.
Thanks.
Flags: needinfo?(zikui.yang) → needinfo?(evanxd)
Hi Elie,

Interesting.
Same, I still could not reproduce this bug in the same environment(Comment 9).
You could check that in the attachment.

Looks like the version in Comment 9 is newer than Comment 11.
Would you like to use the environment(Comment 9) to try again?

Thanks.
Flags: needinfo?(evanxd)
Flags: needinfo?(zikui.yang)
Hey,Evan.I compare my video with yours,I found that we should set the system time as X:XX(ex:4:11 or 4:55).Then,you can reproduce it. Please try again,thanks~^ ^
I can reproduce it today in Flame 2.2:
Gaia-Rev        322ef5116a5827a30c9a3cd9b842449a9c66a5b3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67872ce17918
Build-ID        20141230010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
Flags: needinfo?(zikui.yang) → needinfo?(evanxd)
Hi Elie,
Yes, the play icon overlaped the search box a little bit.
Thanks for the help.
Flags: needinfo?(evanxd)
Assignee: nobody → gmarty
Attached file Github PR
Etienne, can you please have a look at this patch?
Attachment #8544607 - Flags: review?(etienne)
Comment on attachment 8544607 [details] [review]
Github PR

Thanks!
Attachment #8544607 - Flags: review?(etienne) → review+
Landed in master in https://github.com/mozilla-b2g/gaia/commit/6b6e110a6a8f6ae5e93f8fa8427e0672f68c7fb6
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Is this something that should land on v2.1 as well? If so, please request Gaia v2.1 approval on it :)
Flags: needinfo?(gmarty)
Target Milestone: --- → 2.2 S3 (9jan)
This issue dose not exist on Flame 2.2:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111010223
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
Reproduce rate 0/5
Not bad enough to request 2.1 uplift.
Flags: needinfo?(gmarty)
(In reply to Michael Henretty [:mhenretty] from comment #20)
> Not bad enough to request 2.1 uplift.

Flagging Kevin to make sure I did the right thing :)
Flags: needinfo?(khu)
Thanks, Michael. 

It looks minor to me. But, it's worthy to ping Steven to see if we need to have this fix in Dolphin project.
Flags: needinfo?(khu) → needinfo?(styang)
Triage:
Minor issue. Wontfix on 2.1
Flags: needinfo?(styang)
Attached video verify_video.MP4
This issue has been verified successfully on Flame 3.0
STR:
1.Insert headset
2.Launch music and play a song
3.Tap Share icon ->tap messages
**It will promot that the file is too large to share 
4.Tap Ok to return Music view  
**The Play icon is not overlaped with search bar, and the status bar displayed normally.
See attachment:verify_video.MP4
Rate:0/5

Flame 3.0 build:
Build ID               20150215010209
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.043133
Firmware Date          Sun Feb 15 04:31:43 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.