Closed Bug 1074028 Opened 5 years ago Closed 5 years ago

Overlapping rocketbar and statusbar icons for 3rd party apps

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S7 (24Oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: gwagner, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(4 files, 2 obsolete files)

Attached image yelp
Seen on 2.1 with yelp
blocking-b2g: --- → 2.1+
Whiteboard: [systemsfe]
Summary: Overlapping rocketbar and icons for 3rd party apps → Overlapping rocketbar and statusbar icons for 3rd party apps
Assignee: nobody → gmarty
Attached file Github PR (obsolete) —
When the menu button is hidden, the width must be adapted in the maximised state of the status bar only. The minimised state width should remain unchanged as the menu button is never visible.

Ben can you please have a look?
Attachment #8497473 - Flags: review?(bfrancis)
Comment on attachment 8497473 [details] [review]
Github PR

Redirecting the review to Alive after talking to Dale.
Attachment #8497473 - Flags: review?(bfrancis) → review?(alive)
Attachment #8497473 - Flags: review?(alive) → review+
Merged in https://github.com/mozilla-b2g/gaia/commit/db4125ff56efbe3e8951a6e41c1e53a47a46aa5b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please request uplift.
Flags: needinfo?(gmarty)
Reverted for causing bug 1075826.

master: https://github.com/mozilla-b2g/gaia/commit/a7599bb1923dec439dd5e89c7dc9952050bfb132
Status: RESOLVED → REOPENED
Flags: needinfo?(gmarty)
Resolution: FIXED → ---
Attached file Github PR (obsolete) —
This new patch works both with the browser and search apps and doesn't cause the side effects described in Bug 1075826.
Alive, could you please review it?
Attachment #8497473 - Attachment is obsolete: true
Attachment #8498803 - Flags: review?(alive)
Attachment #8498803 - Flags: review?(alive) → review+
Landed in master https://github.com/mozilla-b2g/gaia/commit/ed7deb66e3b329ac0187d379b0c6070813d1d5de
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Comment on attachment 8498803 [details] [review]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Rocket bar
[User impact] if declined: The rocket bar may overlap some of the icons in the status bar on 3rd party apps
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): None as it's a minor CSS change
[String changes made]: None
Attachment #8498803 - Flags: approval-gaia-v2.1?(bbajaj)
Target Milestone: --- → 2.1 S6 (10oct)
Attachment #8498803 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Going to try a fix for this, stealing.
Assignee: gmarty → kgrandon
Status: REOPENED → ASSIGNED
Attached file Github pull request
Work in progress, looking at tests now.
Attachment #8498803 - Attachment is obsolete: true
Comment on attachment 8503461 [details] [review]
Github pull request

Hey Mike - do you want to take a look at this? I tried writing a test, but getting everything to be mocked in the right way for this was extremely difficult, and would probably take a few days. Being that we're coming up on FC, I'd like to get this landed then open a follow-up bug for a test.
Attachment #8503461 - Flags: review?(mhenretty)
Comment on attachment 8503461 [details] [review]
Github pull request

FWIW, I'm not seeing bug 1081138 on master anymore even without this patch. But we are still seeing it on v2.1, and any case this patch fixes it on 2.1. Also measure vs hard coding seems like a good idea in it's own right, so r+.

The only thing that worries me somewhat about this change is that we now measure the rocketbar width every time we update icon visibility. With the frequency of network activity icon show/hide this might be a performance hit. It would be nice if we could cache this, but I won't block on it.
Attachment #8503461 - Flags: review?(mhenretty) → review+
Thanks. I'm still seeing this on master, but the patch is not quite right - it introduces some other problems. I might need to add a few small adjustments to it, and will re-open for review if needed.
Target Milestone: 2.1 S6 (10oct) → 2.1 S7 (Oct24)
Ok - managed to get this into better shape and streamlined some caching into this on the appchrome collapse. Will land once gaia-try is green.
In master: https://github.com/mozilla-b2g/gaia/commit/711daa290264a1ad9a7708fccca05f41d5482a49
Status: ASSIGNED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Depends on: 1082667
The bug still repros on Flame 2.2 and Flame 2.1 nightly.
Actual result: If there are enough status bar icons, they will overlap with the rocketbar when certain apps are open (mainly third party apps).

Flame 2.2
BuildID: 20141015040201
Gaia: 5f1f0960ae9d22acf2a324ad37a48174d6df87f6
Gecko: 62f0b771583c
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 36.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1
BuildID: 20141015001201
Gaia: 379ea4c9dd6d3f8ca2f79ce59c15f6afe6e557c3
Gecko: 4853208cb48a
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 34.0
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [failed-verification]
I need to look into this and verify that the patch was right for v2.1.
Flags: needinfo?(kgrandon)
There was a lot of shifting code introduced by bug 1049439. It seems that no system patch is safe to uplift any more. Here is a branch patch which should fix the issue.
Flags: needinfo?(kgrandon)
Hi Chris,

We're about to land a branch-patch that will fix the issue on 2.1, but I'm unable to reproduce the issue on 2.2. Could you provide us a screenshot of what you are seeing on 2.2? Thanks!
Flags: needinfo?(ckreinbring)
I was unable to repro the bug on today's 2.2 nightly, so I went back to the build where I previously reproed it and got the screenshot from there.
Actual result from today's build: When the rocketbar is present, icons that would overlap it do not appear.

BuildID: 20141020040204
Gaia: dc496d04907dd314f9736ff78bab3bd27156f79a
Gecko: ca6b46cbca3b
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Platform Version: 36.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Flags: needinfo?(ckreinbring)
Branch-patch landed in v2.1: https://github.com/mozilla-b2g/gaia/commit/44aa3a4c71f54dc32df59a640f299e4be342a351

Chris - can you try to re-verify this? Thanks!
Flags: needinfo?(ckreinbring)
The bug still repros on today's 2.1 engineering build with shallow flash.
Actual result: If there are enough status bar icons, they will overlap with the rocketbar when certain apps are open (mainly third party apps).

BuildID: 20141020134135
Gaia: 44aa3a4c71f54dc32df59a640f299e4be342a351
Gecko: 45b98fde47a3
Platform Version: 34.0
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Flags: needinfo?(ckreinbring)
Depends on: 1087710
See Also: → 1097166
This issue does not reproduce on Flame 2.1 and 2.2 anymore.

Result: No overlapping occurs when the rocketbar is minimized. Only 4 icons are shown on the status bar.

Device: Flame 2.1 (319mb, KK, Shallow Flash)
BuildID: 20141111001201
Gaia: 7154f9aa0a69af56c8bd89be0c98d9791449527b
Gecko: 452db1a0c9a0
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141111040202
Gaia: 6af3a8a833eb8bb651e8b188cb3f3c3a43bb4184
Gecko: 76b85b90a8cb
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1111998
You need to log in before you can comment on or make changes to this bug.