[Settings] Show/hide FDN settings based on the availability

RESOLVED FIXED in 2.2 S4 (23jan)

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: arthurcc, Assigned: eragonj)

Tracking

({verifyme})

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.0 wontfix, b2g-v2.0M wontfix, b2g-v2.1 affected, b2g-v2.2 fixed, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [FT:COMMS])

Attachments

(1 attachment)

The phone should show or hide the FDN settings according to the value of EF 0x6F38 and the information will be provided by the proposed API in bug 1112471.
blocking-b2g: --- → backlog
tracking-b2g: --- → +
Wesley, could you help set feature-b2g on this bug? Thanks.
Flags: needinfo?(whuang)
Sure. As this is blocking 2.2 committed scope.
feature-b2g: --- → 2.2+
tracking-b2g: + → ---
Flags: needinfo?(whuang)
Assignee: nobody → ejchen

Updated

5 years ago
Whiteboard: [FT:COMMS]
Posted file patch on master
This is a WIP patch based on API proposal from https://bugzilla.mozilla.org/show_bug.cgi?id=1112471#c3. For this patch, it is still not workable / testable because gecko patch is not ready.

Updated

5 years ago
blocking-b2g: backlog → ---
Hi EJ,
Can you help to provide an ETA date? I think you can set a date after 1/9 Edgar fix bug 1112471. Thanks!
Status: NEW → ASSIGNED
Flags: needinfo?(ejchen)
Flags: needinfo?(ejchen)
Whiteboard: [FT:COMMS] → [FT:COMMS][ETA 01/13]

Updated

5 years ago
Target Milestone: --- → 2.2 S4 (23jan)
Hi EJ,
Edgar has fixed bug 1112471. Just FYI.
Flags: needinfo?(ejchen)
Comment on attachment 8542012 [details] [review]
patch on master

Arthur, please help me review this patch when you have time.

Thanks :)
Flags: needinfo?(ejchen)
Attachment #8542012 - Flags: review?(arthur.chen)
Comment on attachment 8542012 [details] [review]
patch on master

r=me with the nit addressed, thanks!
Attachment #8542012 - Flags: review?(arthur.chen) → review+
Thanks Arthur, let's wait until the tree got opened. :)
Comment on attachment 8542012 [details] [review]
patch on master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no, this is a new feature
[User impact] if declined: users would see fdn section if his/her sim card doesn't support
[Testing completed]: no, we just rely on API to show/hide FDN section
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8542012 - Flags: approval-gaia-v2.2?
Attachment #8542012 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Thanks all ! Merged at Gaia/master : https://github.com/mozilla-b2g/gaia/commit/c7ffbe91e9efd488be8c8d03f8a31a48aee5f223
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 1096815
Duplicate of this bug: 995869
Keywords: verifyme
All of the SIM cards available to qanalysts are able to use FDN so we cannot verify this issue.
QA Whiteboard: QAExclude
You need to log in before you can comment on or make changes to this bug.