Closed Bug 1112505 Opened 7 years ago Closed 7 years ago

FFOS2.0][Woodduck][BT]cannot accept transfer files when alarm is ringing unless stop alarm

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect, P2)

defect

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED INVALID
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: sync-1, Unassigned, NeedInfo)

References

Details

Attachments

(2 files)

PR Reporter:zhensen.su.hz.com
 Office : 0752-2639130 (61130)		
  DEFECT DESCRIPTION:
 >cannot accept transfer files when alarm is ringing unless stop alarm
 
  REPRODUCING PROCEDURES:
 1.Set a alarm in MS.
 
 2.when the alarm ringing, send a file to MS via BT.
 
 3.click the transfer request in status bar.
 
 4.the transfer request cannot show before the alarm screen--KO
 
 PS: it is same in the timer expired screen.
 
  EXPECTED BEHAVIOUR:
 >can show the transfer request before the alarm screen.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Flags: needinfo?(fan.luo)
Keywords: qawanted
Hi Gary,
Could you please help to check the problem? Thanks!
Flags: needinfo?(gchen)
This issue DOES occur on flame 2.2, flame 2.1, and Flame 2.0.  Leaving the qawanted tag for the Wooduck check from Norry.

Environmental Variables:
Device: Flame 2.2
BuildID: 20141217035735
Gaia: d22dfece04fc00457e8369c660c11f945b088d2f
Gecko: cb8ad2251c09
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20141216151310
Gaia: 14315733e2d265a42f9ab02d1aba191789870f70
Gecko: ddecea83ce6e
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0
BuildID: 20141216151108
Gaia: d04710d5d643eeff5a6493aef92a1af672a2769c
Gecko: 4d62570b77e4
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Hi Norry,
 -->
 add test point:
 in the alarm ringing screen,receive voice
 mail,then click the voicemial request in status bar,it has the same issue。
 -->
 Please add above case.Thanks!
Attached video Woodduck2.0 video
Hi,
We don't support voice mail test.
The bug can be repro on Woodduck 2.0 with the steps in Comment#0
See attachments: Woodduck2.0_logcat.txt & Woodduck_video.MP4
Repro time: 13:48
Reproducing rate: 0/5

Woodduck 2.0 build:
Gaia-Rev        7c4ec3494cf465bff688cb4a62f3c2d11a035e14
Gecko-Rev       aa9ece9c8a749095834e7a980166543d985a3af5
Build-ID        20141218050313
Version         32.0
Flags: needinfo?(fan.luo) → needinfo?(sync-1)
Hi Josh,
Please help to check the issue.Thanks!
Hi all,
   This is by design, since alarm dialog's priority is more higher than BT prompt dialog.
   It means user need to close alarm dialog before they click the notification.

   Feel free to re-open it if you have any concern, thanks.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(gchen)
Resolution: --- → INVALID
Dear SPM,
 
 The inner pr has closed,it's mozilla default behavior,please close it.
 
 Thanks!
You need to log in before you can comment on or make changes to this bug.